USB to RS232 driver PL2303 doesn't work on Mac OS X 10.6.8


#1

Hi

I wonder if anyone could help me out here.

I’ve followed instructions at http://plugable.com/2011/07/12/instal… to install the PL2303 driver, version 1.5 on my macbook pro running os x 10.6.8. After restarting my mac, I checked my system profiler and found the device is still not being recognised. Please see the screenshot. !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/914842/Screenshot2013-06-19at12.07.56_inline.png?1371640159)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/914842/Screenshot2013-06-19at12.07.56.png?1371640159)

I then tried to remove it by running:
sudo rm -rf /System/Library/Extensions/ProlificUsbSerial.kext
and reinstall it a few times didn’t help either.

Also I followed tips from this web page: http://www.xbsd.nl/2011/07/pl2303-ser…, didn’t work for me either.

I’m really stuck now, don’t know if this usb to rs232 convertor is going to work on my mac at all? Thanks for any suggestions.


#2

Hi Binjie,

Thank you for contacting us about your USB to Serial adapter. I’m sorry you are having troubles with it.

The adapter and driver should work without any problems with OS X 10.6.8.

We have a tool that can gather the appropriate system information to help troubleshoot this.

Could you install the driver (https://s3.amazonaws.com/plugable/bin…), plug in the USB to Serial adapter, then follow the instructions for Mac at:
It’s at http://plugable.com/support/plugdebug.

Also, if you haven’t already, could you try plugging it directly into each USB port on your Mac, just to make sure a USB port issue isn’t the problem?

Thanks!

David
Plugable Support


#3

Hi David

Thank you for your reply. I’ve given up on that USB-serial convertor, changed to a FTDI USB serial convertor and seems ok. At least it’s showing up in the system profiler correctly.
But when I tried to screen the usb port it doesn’t give me anything back at all, just a blank screen. See the command below:
screen /dev/cu.usbserial-00001004 115200
Any ideas?

Many thanks.


#4

Hi Binjie,

I can’t say about the FTDI device, but if I plug two Plugable USB to Serial adapters connected by a null modem cable into my Mac mini, open two terminals, and issue screen /dev/cu.usbserial 115200 in one terminal, and screen /dev/cu.usbserialx (x=the number assigned to the second adapter) 115200 in the other, I can pass data back and forth between the two. I’m running OS 10.8.4, but I don’t think that should make a difference.

If you cd to the /dev directory and do an ls, do you see the /dev/cu.usbserial device, or any cu.usbserialx devices? You should also see a tty device.


#5

Actually, the /dev/cu.usbserialx command should give you a blank screen. What you type there will go out the port to whatever is attached to it. And whatever comes in through that port should be displayed.


#6