USB to RS-232 DB9 Serial Adapter - Windows 7 not recognizing


#1

My Windows 7 laptop is not recognizing my USB-to-Serial Adapter anymore. It used to detect it and work flawlessly. Now, it is still showing up in under Device Manager\Ports as “Prolific USB-to-Serial Comm Port (COM5)” but when I try to start a Putty session to COM5, I get “Unable to open connection to COM5. Unable to open serial port.”


#2

Hi Jason,

Thank you for posting about your issue with the USB to RS232 adapter. I can help with that.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Could you plug the adapter into your computer, then go to this page and following the instructions there:

http://plugable.com/support/plugdebug

Please send the result to support@plugable.com and mention ticket number 36044 in the subject line.

Thanks!

David
Plugable Support


#3

Just sent it. Thanks for your help.


#4

Hi Jason,

Thank you for sending the log files. I’ve looked at them, and the driver installation appears to be having problems.

If you are still seeing “Prolific USB-to-Serial Comm Port (COM5)” in device manager, please right-click it, select uninstall, and on the confirmation window that pops up after that, please put a check in the box that says Delete the driver software for this device.

There is a new driver available for the USB to serial adapter. Please download it from this link and install it:

http://www.prolific.com.tw/UserFiles/…

Thank you,

David


#5

Prolific USB-to-Serial Comm Port (COM5) is still not showing up in device manager. I installed the new driver and tried plugging in the adapter again after installation completed, but nothing happens. My machine doesn’t appear to detect it at all. I tried it on another computer, and it didn’t detect it either. I tested the USB port on the computer with a thumb drive and it’s working properly. Is there anything else I can try?

Thanks,
Jason


#6

Hi Jason,

We will be sending you a replacement adapter. I have sent a message to your personal email asking for the information we need to send it to you.

Thank you,
David


#7