USB to RS-232 DB9 Serial Adapter-Technical Issue


#1

I bought this: Plugable USB to RS-232 DB9 Serial Adapter (Prolific PL2303HX Rev D Chipset) to be able to connect my Windows 7 Home Premium laptop to my Singer XL-6000 embroidery/sewing machine. The cable that came with the sewing machine had pin connectors at both ends. My laptop does not have a pin connector - only USB ports. So, I loaded the driver program for the new connector to the laptop. Turns out the pin connector on the new cable was not correctly configured to plug directly into the sewing machine. So, I was able to plug one end of the old cable into the pin connector end of the new cable, then connect the old cable to the sewing machine. Next, I open the Singer Sew Ware conversion software (for embroidery) on my laptop. I get an error message - something like “Error in cportio.sys driver,” but I click OK and am able to open the purchased applique design file (stored on a thumb-drive connected to my laptop). So far so good. Next I check the baud rates to ensure they are the same on the sewing machine and the laptop. Instructions that came with the new cable said the COM port is automatically set to 4, and to communicate with older devices you’d need to change it to a lower setting from 1 to 4. So, I had changed the COM port on the laptop to the lower setting. I tried 1 and 2. Neither worked. Each time I try to transmit the design following the transmit instructions included in the sewing machine’s user guide, I get an error message saying something like “transmit failed” or something like that. What I’m doing wrong? Thank you so much in advance!


#2

Hi Sherry,

Thank you for contacting us about using your USB to serial adapter with your sewing machine.

It is possible that COM ports 1 and 2 are being used internally by other devices, and there is a conflict there. If the adapter is set for COM 4 in Device Manager, is it possible to also set COM4 in the Singer Sew Ware software?

There are some instructions here, but the appear to apply to Windows XP, and may not work for Windows 7: http://www.psw-support.com/Support/su…

Were you able to successfully use this software with another computer in the past? What was its Windows version?

Can you also tell me what version of the Sew Ware software you are using? Depending on what version you have, there appear to be some updates online that might help.

Thank you,

David
Plugable Support


#3

Thank you for your prompt reply.

I’m pretty sure that COM ports 1 and 2 are not being used, as Windows indicates which ones are in use by placing the parenthetical phrase (in use) next to the one(s) being used. The only COM port that is evidently being used is COM port 3.

I have never used the software with another computer in the past. The version of Sew Ware I’m using is v1.00. I know there are update downloads on the Singer website, but each time I try to download them, I get an error message saying I don’t have the v1.00 software installed. I am CERTAIN it is installed, because I can open it and then open up purchased embroidery design files within the program.


#4

I also forgot to say that I have also tried COM 4, without success.


#5

I received the following response to my issue from a well-establish sewing forum specializing in Singer Quantum XL-6000 issues. How does the USB to RS-232 DB9 Serial Adapter (Prolific PL2303HX Rev D Chipset) compare to the ones the sewing forum recommends?

"We have found that the PSW works best on newer computers when the USB serial adapter cable has
not only compatible drivers for the Windows Operating System but also a FTDI chip.

"We have found this chip in several cables which are listed below.

CUSB-232A available from the following retailers:

Computerplug.com
Cablesalesusa.com

10U1-06103 available from:

CableWholesalers.com"


#6

Hi Sherry,

Our adapter does not contain the FTDI chip. It contains a Prolific chip. There are some subtle differences between the two, and we have found that some software that works with our chip doesn’t work on the FTDI chip, and some that works on that chip does not work on ours. This may be what is happening in your case.

It seems like there are several possible issues here:

  1. The inability to update the software.
  2. The possibility that the software is incompatible with Windows 7 (perhaps causing issue #1).
  3. The software does not work with our chip, but works with the FTDI chip.

I would suggest asking on the forum about the first two issues. If you are able to get the software updated, and if the experienced people on the forum can tell you they have used to software on a Windows 7 computer, ask them how they did it. If they all used an adapter with an FTDI chip, then maybe that software will not work with our chip. If that turns out to be the case, then please feel free to return the adapter to Amazon for a refund under their 30-day return policy. We don’t want you to be stuck with a product that isn’t going to work in your application.

I hope this helps,
David
Plugable Support


#7

Thank you, David. You’ve been very helpful. I have one more question that you may or may not be able to answer for me:

There is a feature in Windows 7 that allows you to run programs made for previous versions of Windows. When I installed the Sew Ware, I used this feature, so theoretically, the software should run successfully, right?

Thanks again for all your help. I especially appreciate being able to return the cable for a refund if I’m unable to get it to work.

Sherry


#8

Hi Sherry,

I know the feature you are talking about, the Windows compatibility feature. It does help from time to time, but there are some older programs that just won’t work with Windows 7 at all. I had a similar situation where I was trying to use the adapter to connect an older drawing tablet that used a serial connection. The connection was successful, but I couldn’t run the software in Windows 7, even with compatibility mode. We finally got it working on an Windows XP machine.

I think you best bet would be to ask on that forum if anyone has gotten it working on a Windows 7 machine, and how did they do it. Honestly, my gut feeling is that if it does work on Windows 7, you may end up having to get an adapter with the FTDI chip.

David


#9