USB to HDMI blinking on Ubuntu 17.04


#1

I’ve been using plugable usb 3 to HDMI adapter on ubuntu 16.04 for the last year, and it has worked perfectly. Now, I updated my ubuntu to 17.04, and it stopped working. I then updated the displaylink drivers to the latest version, which didn’t change anything. I then also updated other parts of my system, including my BIOS, and again no change.

The problem seems to be that the device keeps disconnecting and then re-connecting via USB to my computer. While this is happening, the monitor does not appear in the system. This is visible through a blinking blue LED - it turns on and off every two seconds. This is further confirmed when I run lsusb -d 17e9: : If I run it while the light is off, I get nothing, while I get the following if the light is on:
Bus 002 Device 110: ID 17e9:4324 DisplayLink

This is independent of whether the device is connected to a hub or to either of my two USB ports directly. In addition, yesterday, for some reason, the device decided it had enough for the blinking randomly after I had been working with the device in that state for multiple hours, and it suddenly started working. As soon as the blinking stopped, ubuntu recognized the monitor, and let me use it perfectly. After a reboot of the system however, the device went back to blinking and does not let me use the monitor. When I use windows, the device works fine, so this is clearly not a hardware issue.

Checking dmesg, I keep getting:

[949.250549] usb 2-2.4: USB disconnect, device number 91 
 [950.501508] usb 2-2.4: new high-speed USB device number 92 using xhci\_hcd 
 [950.602689] usb 2-2.4: New USB device found, idVendor=17e9, idProduct=4324 
 [950.602694] usb 2-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 
 [950.602698] usb 2-2.4: Product: Plugable UGA-2KHDMI 
 [950.602701] usb 2-2.4: Manufacturer: DisplayLink 
 [950.602703] usb 2-2.4: SerialNumber: 60385174 
 [950.608332] usb 2-2.4: Warning! Unlikely big volume range (=511), cval-\>res is probably wrong. 
 [950.608337] usb 2-2.4: [13] FU [UGA-2KHDMI Audio Playback Volume] ch = 6, val = -8176/0/16 
 [950.614195] usb 2-2.4: usbfs: process 1609 (DeviceManager\_0) did not claim interface 1 before use 

Any idea what is going on, and how I can fix the device disconnecting? I e-mailed my plugdebug to the support.


#2

Hi Michail, thanks for posting! We had also had an email support ticket that we had already responded to and I will paste that response below:

"Unfortunately, we do not support our adapter on Ubuntu and other Linux distributions as there can be several compatibility issues, similar to what you are experiencing. We do our best to call this out on our Amazon product listing, but we are always looking for better ways to convey this compatibility information.

I apologize that I cannot be of more assistance, but I would be able to help with a return for full refund directly to us as we certainly do not want you to be stuck with an adapter that does not work for you."

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3