usb to ethernet on macbook air not working?


#1

Hi,
I just bought a
Plugable USB 2.0 to 10/100 Fast Ethernet LAN Wired Network Adapter for Macbook, Chromebook, Windows 8 and earlier, Wii, Wii U, Linux, and Specific Android Tablets (ASIX AX88772 chipset)
on Amazon, and received today. I plugged it onto my Macbook Air late 2010 version running Mountain Lion 10.8. It shows that the ethernet cable is connected in network settings, but it is not showing up in the menu bar even if I close the Wi-Fi, I even tried installing the driver from the download page, but still it shows connected to ethernet but is not running.
Can you please help with that, or should I return the item and get my refund back for this item.
Please help!!!


#2

Hi Sujan,

Thanks for contacting Plugable Support, I’ll be happy to assist. We’ve also sent this response to your contact through support@plugable.com so feel free to reply to either one.

To get started troubleshooting, I’ll just need a bit more detail.

First, can you please send a message to support@plugable.com with your Amazon Order Id?

Next, can you say what happens if you connect the ethernet cable to another device?

Can another device successfully connect over the same cable?

Let me know these details and we’ll figure out the best next steps to get you running.

Thanks,
Jerome.

Plugable Technologies


#3

Amazon Order Number: 106-7892366-3258656.
I havent tried another computer yet, but I am a student at a University, and am using the school’s ethernet supply in my dorm room due to weaker wifi connection. I will try it in another computer maybe tomorrow. But i just wanted to know if the school might be blocking it or not. If that’s the case then the ethernet cable works perfectly in my roommate’s windows machine, but not on my Macbook Air. I am attaching this picture of what happens when i plug in the usb to ethernet on my mac.
My computer is Macbook air late 2010 version with mountain lion (10.8) installed on it. !](https://d37wxxhohlp07s.cloudfront.net/s3_images/847127/Screen%20Shot%202013-01-22%20at%207.32.59%20PM_inline.png?1358904622)](https://d37wxxhohlp07s.cloudfront.net/s3_images/847127/Screen%20Shot%202013-01-22%20at%207.32.59%20PM.png?1358904622)


#4

it doesnot show up the Router, DNS, etc…


#5

Hi Sujian,

Thanks for sending in the picture of your network connection information, it looks like your machine isn’t getting an IP address assigned. It could be that the network isn’t providing an address via DHCP or possibly the driver didn’t install correctly.

To verify that the drivers are installed correctly, follow the steps outlined in this blog post:
http://plugable.com/2011/07/27/howto-…

Once you have completed the steps in the post your drivers should be installed correctly.

Let me know how it goes.
Thanks,
Jerome.


#6

oh, sorry for the trouble. I went to talk to the University network administrators, and they told that my mac machine should be registered for using the ethernet. I am able to use it now. But thanks for helping. This is a cheap but great product that I bought. Thanks Again.
Sujan


#7