USB Serial Converter not working with new MacBook and USB to USB-C Adapter


#1

Tried my tried and true Plugable USB Converter for the first time with my new MacBook laptop with the Apple USB to USB-C adapter. It did NOT work. Then tried it once again in my MacBook Pro 13" late 2013 and its still works. Is a new driver needed for a new MacBook laptop with the USB-C adapter?


#2

Hi Issac,

Thank you for posting about your USB Serial adapter. I’m sorry it didn’t work in your new MacBook.

There shouldn’t be a problem, assuming the USB Standard to USB-C adapter is working OK.

Did you install the driver software on the new Mac? There is an updated version for El Capitan:

https://s3.amazonaws.com/plugable/bin…

Please try that if you haven’t already.

Thank you,

David
Plugable Support


#3

Thanks David for your prompt reply. Yes I did load the new driver. I then waited till my MacBook rebooted. I then went to the About this Mac menu selection, then selected system report to verify that the driver was listed as under the Hardware USB section. What I noted in my terminal session was that as I struck the return key, the handshake led’s were not indicating any interaction.

I then took the very same Pluggable Serial Converter and plugged it into my MacBook Pro 13" and it worked as expected. Really scratching me head on this one. Any other suggestions?


#4

Hi Issac,

Please try opening a terminal and typing:

ls /dev/ | grep usbserial

You should see two results:

cu.usbserial
tty.usbserial

If you do, it should be OK.

Can you tell me which device you are connecting to through the RS-232 interface?

Thanks,

David


#5

I am connecting to the cu.usbserial connection


#6

If you are seeing the cu.usbserial device, that is good.

Actually, though, I was hoping to find out what was at the other end of the serial cable. Maybe we need to change port settings or something.

Also, what communications software are you using?

Thank you,

David
Plugable Support


#7

David…got it work! Not quite sure why, but here’s how. I use a Terminal emulation program called Zoc6. I built a pfsense firewall with a Alix motherboard that has a serial port connection. In Zoc6 I usually use a connection type called Serial/Direct at 9600 8n. I discovered that I had to use a connection type called Serial/Modem to get it to work with my Serial Converter. Again not sure why but it works great now…thanks for your help…happy camper here!


#8

Hi Issac,

I’m glad you got it working!

I’m not sure why it was different in this case, but when connecting two devices through a modem, you connect send to send, while in a direct connection, you connect send to receive, using a null modem cable.

David


#9

Hi Issac,

I’m going to close this thread. If you have any additional questions, please contact us at support@plugable.com. Thanks!


#10