USB-serial adapter - Xmodem file transfer fails


#1

I am trying to execute an Xmodem file transfer using the Plugable USB-to-serial adapter at 115,200 baud of a Cisco IOS .bin file from my Windows 7 laptop to a Cisco 2610XM router via Tera Term client. I am able to connect and initiate the transfer, but eventually the output becomes a jumbled mess and the whole thing hangs. Is the USB-serial adapter capable of these kinds of transfers?


#2

Hi Jason-

Thanks for posting with your question!

Two quick options seem like they would be worth investigation:

  1. Does setting a lower baud rate (9600 is recommended) help?

  2. Does using HyperTerm instead of TeraTerm help?

At least one user has reported that using HyperTerm in his Windows 7 systems Windows XP mode virtual machine worked:
"Re: Xmodem I/O error when copy IOS from tftp server
The document I read ( http://www.cisco.com/en/US/products/h… ) does not specify an OS and does it requires a specific terminal emulator.

However I could not get to to work under anything except HyperTerminal under Windows XP 32 bit using 9600 baud. I actually used a Windows XP Mode VM under Windows 7 with a pass through USB to Serial device and it worked like a charm.

I tried MANY different terminal emulators including Ponderosa, TeraTerm, SecureCRT, HypeTerminal (for Windows 7) and probably a few others. Nothing worked!" from https://supportforums.cisco.com/threa…

The documentation link in the quote above also recommends setting the lower Baud rate, which may be necessary on both sides of the connection, PC and 2610XM. The steps posted here should help with this, if needed. http://www.cisco.com/en/US/products/h…

I hope this helps, but please let me know if you’ve any other questions or if this doesn’t do the trick.

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#3