USB Mouse/Keyboard do not work sometimes after resuming use.


#1

Every so often my mouse and keyboard hooked up through the USB-C triple display docking station do not work after boot up/resume and I need to unplug the power from the docking station to get them working again. They have never stopped working while I actively used it. I am using a 2016 TB Mac.

I have not been able to pinpoint the exact sequence of steps to make this happen. But last time it happened after I have been using the hub, then disconnect from the hub, then shut down my computer while off the hub then plug in the hub before turning the computer back on.


#2

Hello Matthew,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Can you tell me what model mouse and keyboard you’re using?

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3

Yes, I am using a Microsoft Natural Ergonomic Keyboard 4000 and a Steelseries Rival 7000 optical mouse.


#4

Hi Matt,

Thanks for the info and my delayed reply over the weekend. So both wired models, neither of which I am familiar with having known issues.

Do other USB devices also require being unplugged and plugged back in?

Lastly about your Mac, can you tell me if it is the 13" or 15" model, with or without touchbar?

Thanks,
Josh


#5

I have a 15 inch model with the Touch Bar. I do not think it is related to the type of devices. To be clear, I don’t plug in and out the devices, I will check next time it happens, but that does not fix it. I unplug the entire Hub from the power and plug it back in.


#6

Hi Matt,

Thanks for the update. So basically when this happens, you have to reset the entire dock.

We may need to look into replacing the dock under warranty. Can you contact us directly at support@plugable.com with your Amazon Order ID, serial # off the bottom of the dock, and the best shipping address?

Thanks,
Josh


#7