USB microscope will not work

I just purchased the USB microscope 250x and can not get it to work with the software. It worked for a couple minutes and then just stopped. I have tried the “fixes” in these FAQ’s and none seem to work. I do not have oculous and am running Windows 10. It is being recognized as USB Microscope in device manager as a camera.


Thanks for reaching out to us! I do apologize for the trouble, and am here to help. Let’s check to make sure that your camera privacy options are set.

I’d like to point you to an article on our website where we outline the steps to check for this:

If you would, please give those steps a try and let me know what happens. If you are still having trouble, please make sure the microscope is connected, and run our diagnostic at the following link:

A zipped folder with the results will be placed on your desktop after running the tool. If you would, please provide the results and your Amazon order number in direct response to the email, and not on the forum.

Thank you,

Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.