USB Hub won't power on


#1

I have a USB3-hub7-81x. All of a sudden it has lost power and will not power back on. I have only had the unit for about 6 months if even. Please assist.


#2

Hello Mitchell,

I am sorry to hear this. Please make sure all the connections to the USB hub’s are tight and try a different power plug (if you have not already done so). If we end up with the same symptoms, please contact me directly at support@plugable.com with the following details:

  1. Amazon order ID.
  2. Serial number from sticker on bottom of unit.
  3. Shipping address.

Once I have these details I can send you a pretested replacement unit to rule out hardware failure.

Kind regards,
Patric
Plugable Technologies


#3

Thanks I have forwarded an email.


#4

Hi. I have the same problem. It’s worked for a week or so and then now it won’t power on. I changed out the plugs and restarted my computer. Nothing. Should I send you the same information?


#5

Hi Alec,

Yes please.

Kind regards,
Patric
Plugable Technologies


#6

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1301181/English212LindquistWebsiteHomePage_inline.jpg?1446135817)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1301181/English212LindquistWebsiteHomePage.jpg?1446135817)

I just received this unit today; there is no power; I’m pretty tech savvy and tried everything; it just doesn’t turn on. Was expecting good things. Do I follow the same directions as indicated for others. Thanks. – Ed


#7

Hello Ed,

Please contact me directly (as shown in my first response). In addition, please perform a USB hub reset by doing the following:

  1. Disconnect USB hub from power and computer and wait for 120 seconds (also disconnect all peripherals from USB Hub)
  2. Connect USB hub to power only and wait for another 10 seconds
  3. Connect USB hub to computer and test all USB ports with a simple USB device such as a wired mouse or keyboard
  4. Now connect your usual peripherals and test

Please also post the results of this test in the direct reply.

Kind regards,
Patric
Plugable Technologies


#8