USB hub will not install, Windows Xp reports multiple problems.


#1

Plugged in hub, then powered up Windows XP, SP3.
Device manager finds new HW and then tries to install “Generic USB Hub” driver.

Process then warns that the software “has not passed windows logo testing”. Hit continue anyway.

The device manager then fails saying “The system cannot find the file specified”!

Help. Is this a hardware problem? My old hub worked fine. How do I replace that driver? Windows update is no help.


#2

Hi Mike,

Something unusual is happening on your system, because the hub (like all standard USB 2.0 hubs) does not require any special driver - it uses the Microsoft drivers already in Windows (usbhub.sys).

So a few quick checks/tips:

* For the device that’s coming up bad in device manager, can you open its properties, go to “Details” tab, select “Hardware IDs” from the drop down, and post the top/long line here?
* Can you post the size and date of the file \windows\inf\usb.inf (which is the file Windows XP should be matching on to get the Windows-supplied hub driver)

We’ll get this figured out! Thanks for your patience!
Bernie


#3

Apparently my last reply didn’t stick?

Anyway, Thanks for the quick response.

Two yellow-flagged devices…

Under “Generic USB Hub”:
HW ID: USB\VID_1A40&PID_0201&Rev_0100

Under “USB 2.0 Hub”:
HW ID: USB\VID_1A40&PID_0101&Rev_0111

\windows\inf\usb.inf :
08/29/2002 05:00 AM 20,623 usb.inf


#4

Hi Mike,

Thanks for the reply with this good info. Ok, great, those IDs are coming from our 10 port hub.

What’s really interesting is the usb.inf (which is part of Windows itself). With Windows XP SP3, the date on that file should be 4/13/1998 and the size 20623. So it doesn’t appear you have an XP SP3 version of that file.

Let’s also see what the USB drivers in Windows have for date. Can you check

\windows\system32\drivers\usbhub.sys
\windows\system32\drivers\usbport.sys

Both should be dated 4/13/2008 (going off my XP SP3 system). What do you have?

We’ll get this mystery figured out. Thanks!
Bernie


#5

04/13/2008 11:45 AM 59,520 usbhub.sys

04/13/2008 11:45 AM 143,872 usbport.sys

Both “About Windows” and Windows update *say* I have SP3. But apparently something’s fubared since I swapped out these hubs?


#6

Yes, this is it.

It appears something has overwritten \windows\inf\usb.inf (possibly with the version from the original pre-SP3 Windows XP), which would mean all new USB devices have a good chance of failing to install properly.

We need to replace that file with one from an actual XP SP3 machine. Do you have another around that you could take usb.inf from?

If not, we can email you a copy. Just email support@plugable.com and we’ll reply back.

Thanks - I’m hopeful we’ll get this solved quickly now.


#7

Thanks.

This is the only Win XP machine I have at the moment.

Sent email and I also have an SP3 CD on the way.


#8

Sent the email and got back a usb.inf dated 4/13/2008 and only 21Kb.
Tried it anyway… Same problems.


#9

After email and phone exchanges, Bernie pointed me to this article: http://support.microsoft.com/kb/822798

The instructions and “fix it” utility solved the problem.


#10

Very glad we could get this interesting case solved! This turned out to be a problem unrelated to the product, with XP’s cryptsvc service and its database. For the benefit of others, the main clue was this error message:

#W239 The driver signing class list “C:\WINDOWS\INF\certclas.inf” was missing or invalid. Error 1168: Element not found. Assuming all device classes are subject to driver signing policy.
#E358 An unsigned or incorrectly signed file “c:\windows\inf\usb.inf” for driver “Generic USB Hub” blocked (server install). Error 1168: Element not found.

in \windows\setupapi.log

And that error led to guessing this machine had corruption of XP’s %Systemroot%\System32\Catroot and catroot2 databases (which apparently is not uncommon).

This has a whole bunch of effects, some of which are listed in Microsoft’s knowledge base article. Fortunately, Microsoft has a “fix it” utility which makes cleaning this up easy, listed in the resolution section

http://support.microsoft.com/kb/822798

Hope this helps someone else who might hit the same error (could happen on any hardware).


#11