USB gigabit ethernet STALLS on Mac OS 10.11.2


#1

I have a PLUGABLE USB 2.0 10/100/1000 GIGABIT ETHERNET ADAPTER and it’s worked fine for quite a while, but since updating to OS 10.11, I’ve had a problem where the speed starts out fine, but after anywhere from 5 minutes to a couple hours, it slows down to unusable speeds and then stops working.

Unplugging the adapter and plugging it back in does not get it working again - the only thing that fixes it is a reboot. While it’s having the problem, if I connect to my router via wi-fi, the issue goes away - so that leads me to believe the issue is with the adapter, not any wiring. I’ve also tried the adapter both with a hub and also directly plugged into my computer’s USB port, but the problem persists.

I read this on the product page:

Notes for Mac OS X 10.11: Currently the chip set manufacturer ASIX hasn’t released the official driver installer yet. We have tested this adapter with an Macbook Air 10.11.1 with the latest driver version 2.1.0 (Release Date is 2014-11-06) installed, and verified it works.

This makes me skeptical. Have they really tested it rigorously? It seems to work for me at first too, but then it fails. Help please!


#2

Hi Jason,

Thank you for posting the question here.
The symptom you are seeing is very strange, and we haven’t heard from other customers nor seen it here in our environment.

I’ve tested the USB2-E1000 (plus Plugable Type A-Type C adapter) with our Macbook Retina, 12" 2015 version 10.11.3, and couldn’t reproduce the issue. I think you are using the same driver 2.1 with me: it’s still the latest one from ASIX.

Could you send us the debug files by using our Plugdebug tool, directly at support@plugable.com?
http://plugable.com/support/plugdebug

Thank you for working on this with us!

Sachiko
Plugable Technologies


#3