USB_Gigabit_Ethernet AX88178 on MAC Lion: No router/DNS Server


#1

I installed the latest driver package (AX88178, v3.6.0) on my mac 10.7.1 OS, and connected it to my Linksys 5-port switch, which in turn is connected to a linksys router on my DSL modem. When I configure it for a connection (network, Location: USB_Gigabit_Ethernet ) I get and IP address (169.254.88.16) with a subnet Mask of 255.255.0.0 and no router and DNS Server, and I cannot make a connection out. (On my windows machine, connected to the same switch I get reasonable values: IP address of 192.168.1.104, subnet mask 255.255.255.0, gateway 192.168.1.1 and Dhcp server 192.168.1.1 (of the router), and DNS servers 68.94.156.1, 68.94.157.1.)
I would appreciate any help. (I’ve tried setting the DNS service manually, but to no avail, and there doesn’t seem to be any other controls through this (System Preverences) interface. If need be, I won’t mind doing any network changes/admin commands in a bash shell.)
Thanks,
knt


#2

Hi kent,

It sounds like your adapter is not getting an address assigned by DHCP. The 169.254.88.16 address is a default that shows up after DHCP fails, so let’s try and find out why it’s not getting an address.

A quick test is to power cycle your network equipment, all the way up to the DSL modem and turn it all back on with your Gigabit ethernet adpater connected. Sometimes services limit the number of hardware interfaces that they will give addresses to and will reset the list upon being power cycled.

If that doesn’t help you can verify that the drivers are installed and that the cable and other hardware up to and including the Gigabit adapter are functioning by setting an IP address manually and trying to ping other machines on your subnet.

This is done in the same system preferences menu where you checked the IP address before, but you’ll want to configure ipV4 manually instead of using DHCP in the drop down menu. Use settings similar to those or your Windows machine above. Choose a different value for the last octet of the IP address eg: 192.168.1.xxx where ‘xxx’ is something close to the value above of 104, something like 125.

Apply the settings and open an X terminal. Try to ping 192.168.1.1.

If it works, you’ll know the adapter has a valid driver installed and the cable is live.

Let me know what you find~
We’re here to help!
Jerome.

Plugable Technologies


#3

Jerome,
Thank you. Excellent instructions.
I finally reinstalled the driver, tried the manual setup and a ping check (that worked), and then went back to dhcp, and that worked well.
I’m hardwired now!
Thank you sir.
Kent


#4

Hey Kent,

That’s great, I’m glad you are up and running.

Let us know if there’s any thing else we can do,
We’re here to help!

Jerome

Plugable Technologies


#5