USB Extension Cable Not Working on Ubuntu


#1

I can’t get the 10m plugable USB extension cable to work on linux (Ubuntu 12.10 64-bit). The cable works fine on a Windows PC, so it’s not an issue of a broken cable. However, plugging it into any of my USB ports on my linux machine gets no reaction at all. Can anyone help me?


#2

To give a bit more information; after plugging in the extension cable and running lsusb, I can see it among the list of usb devices. However, whenever I plug a device (my printer, a usb drive, anything) into the cable, it doesn’t show up in the list. What’s more, it seems to crash Ubuntu’s drivers, and I can no longer plug anything else into any of my USB ports, even after removing the cable.


#3

Hi Matthew-

Thanks for posting with your issue, I’ll be happy to help.

I’ve just tested the USB 10 meter cable between a simple USB flash drive and my Ubuntu virtual machine, and am having no issues here. I also tested on a fedora 18 box running on bare metal, and found that lsusb didn’t list any additional devices after plugging in the cable and flash drive.

We’ll look into this further and let you know what we find, however this may take some time to resolve. If you need to make something happen right away I’m afraid a return may be your best option, however you may see similar issues with other devices since a generic driver is used for the Terminus Technology hub chip used in the cable. Since the cable relies on a generic driver, any changes we make here could affect whether other USB hubs work as well.

Sorry I can’t share better news, however I can at least verify that we’re seeing a similar issue on newer linux distributions as well. We’ll post back with further updates as soon as we have them, and please let us know if you find anything worth mention.

Best wishes-

Jeff Everett
Plugable Technologies


#4

Hi Jeff,

Thanks for your reply. I appreciate you taking the time to look into it, and that’s what makes me want to stick with this product instead of just returning it and trying with a different one. I’m fairly positive it is a problem with Ubuntu and not your product anyway.

If there’s any other information I can supply to help you out, please let me know. So far, the only thing I can really report is this: when I plug in just the USB cable and run lsusb, I can see the Terminus Technology hub in my list of devices. After this, if I plug anything at all into the extension cable, nothing else shows up. On top of this, plugging anything else into the computer’s USB ports results in nothing. I can’t plug in any new usb drives or devices; however, my usb mouse and keyboard still work.


#5

Hi Matt-

Thanks for the follow up details, this is very helpful.

A couple of us (self included) have Ubuntu 12.10 installs at home- I just forgot to bring an extension home to check with that today. The fedora 18 system I did the first check on didn’t show the terminus chip under lsusb at all: i think the Ubuntu Parallels VM only worked because handling of the Terminus “hub” in the extension was handled in OSX, then only the flash drive I put on the cable was passed by Parallels to the VM.

Based on these initial details I suspect that this will turn out to be an issue that has to get resolved on the Ubuntu forums, but we’ll at least try to help with finding the right thread.

Please post back with any other observations you have and I’ll follow up once we’ve looked into this on a 12.10 system running on bare metal rather than a virtual environment, this should be tomorrow if not this evening. I’m confident we can get to the bottom of this with your patience :slight_smile:

Best wishes-

Jeff


#6

Hi Jeff,

I’ll try this on another Ubuntu PC this week and see if there is a different result. In the meantime I have started a thread on the Ubuntu forums, but I haven’t gotten any replies yet, nor could I find anyone with similar issues. Hopefully you’ll be able to figure something on your end…


#7

Hi Matthew-

I’ve tested this out on my Ubuntu 12.10 system and am having no issues using a couple of USB devices (Logitech USB headphones/mic and SanDisk Cruzer USB 2.0 flash drive) when connected via the cable. I was surprised that lsusb didn’t have an entry for the cable, however bus and device #'s change based on whether the cable is present or not.

I’m not sure what the deal with the other fedora 18 system was, but mentioning that might help the ubuntu folks. I can try to duplicate the error there and post something if logs are requested somewhere, but this is looking like it might be a system specific issue.

What do you get for uname -a ?

I was initially on 3.5.17 on the system that’s working fine, updated to 3.5.26 and that was also fine. Only after updating and rebooting to load 3.5.26 did a “Terminus Technology Inc. 4-Port HUB” appear under LSUSB.

I’ll be curious to hear if you make any progress on your end. Please let me know if you’ve any other questions.

Best wishes-

Jeff


#8

Hi Jeff,

Today I tried the cable on my tablet PC, which runs Lubuntu 12.10, and the cable worked fine on it, so I’m 100% sure this cable does not have a problem. I am still getting intermittent problems on my Ubuntu PC. This evening at one point I was able to get the cable to work with my USB drive, then I plugged in my printer and it didn’t work, then I re-plugged it and it worked… It seems to be working at the moment. I’m not sure what caused the change, but there was a software update this morning and I wonder if that had anything to do with it.

Just in case its helpful at all, uname -a gives me this: Linux GLaDOS 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Anyway, this appears to be a closed case. I really appreciate your personal response and the time you took to reply to my messages and investigate my problem. I’m really happy with the customer service. I’m definitely going to buy more Plugable products in the future. Thanks for your help.


#9