USB-ethernet drivers not available for Windows 7 Ultimate?


#1

I’ve just received a USB-to-ethernet device (model USB2-E1000) and am trying to install the driver. I’m running Windows 7 Ultimate, 32-bit. I’ve tried both sets of drivers, but nothing works; in fact, none of the names even indicate that the drivers have been updated for Windows 7. Is there something I’m not seeing, or do the drivers not in fact work for W7?


#2

Hi Louis,

Thanks for posting. Win7 32-bit is no problem at all, let’s figure out what’s gone wrong in terms of finding drivers.

On the driver CD included in the package, there should be a Windows\Windows7_v1.x.3.7_Drivers directory with the drivers you need. Does your driver CD look different?

But we always recommend downloading the latest drivers anyway to get all the most recent features and fixes. Our driver page is http://plugable.com/support/drivers and in particular all the drivers for the USB2-E1000 are here:
http://www.asix.com.tw/download.php?s…

The “Home/Pro/Ultimate” designation doesn’t matter. What you’re looking for is the “Windows 7 32-bit/64-bit Drivers Setup Program” on that list. Here is the direct link: http://www.asix.com.tw/FrootAttach/dr…

You will need a program like WinRAR to uncompress that package from ASIX.

Please let us know if you have any trouble at all with this info. We’re here to help. You can also email support@plugable.com

Thanks,
Bernie


#3

I didn’t receive a driver CD with the package, so I went straight to this site. I downloaded the “Windows 7 32-bit/64-bit Drivers Setup Program” and uncompressed the package with 7-Zip. I tried setup.exe on the first screen but it says “Error reading setup initialization file”, so I tried DPInst.exe under the 32-bit folder, but that setup wizard says that there are no drivers designed for my machine.


#4

Hi Louis,

No problem, we’ll help.

The driver CD is a little hard to find - it’s a mini-CD, and it should be tucked in-between the two halves of the inside paper packaging (along with a quick start manual). If you still have the package - can you check again - is the CD missing (and is the manual)? We’d like to know so we can flag a factory problem if it is. Our apologies and thanks!

On the downloaded package, the “Error reading setup initialization file” error happens when you open the archive in 7-Zip and launch the setup.exe program from within 7-Zip, without having uncompressed the driver package to disk (7-Zip uncompresses setup.exe and runs it - but then setup.exe can’t access any of the other files in the archive that it needs).

The solution is quick. Go back to where the .rar file is, right click, and choose the 7-Zip’s “Extract Here” option to extract the whole archive onto your disk. Then go into that extracted folder and click the setup.exe program. It’ll now not hit that “Error reading setup initialization file” error.

Thanks for giving both a second look, and letting us know how it goes now,
Bernie


#5

And my problems have been solved! After a second look, I did find the driver CD and manual, so there’s no manufacturing error. I did exactly as you said for 7-Zip and everything worked out. Thank you very much, Bernie!

  • Louis

#6

Hi Louis.

Great! Glad to have you up and running! We’re looking at updating the packaging to make the location of the driver disk much more obvious - that’s our packaging design problem!

Thanks for your patience,
Bernie


#7

I think the physical packaging itself is quite good. Looking at it from the front after you take out the adapter, all that you can see is a white space surrounded by a green border. Perhaps you could put an image of a disc in the white space to let people know immediately that the disc is behind that paper cover? Alternatively, you could have a little tab on the paper cover that says “Pull here” so they can find the disc behind it. In any case, thank you very much for the help!

  • Louis

#8

Hi Louis - good suggestions! We’ll certainly be making a packaging update.


#9