USB Ethernet adapter installation issues


#1

Running Windows 7 64 bit on desktop computer. Installed driver for Win 7 but computer does not recognize the deveice. It does not appear in Device Manager. I did plug the devide in too early, before installing the sofware from CD. Cancelled the autoplay install, installed the Win 7 driver but no connection. When I plug the ethernet cable into the devicethe light does come on steady.

I will appreciate any assistance.


#2

Hi Steve!

Thanks for contacting us and sorry to hear you’ve been having problems with the Gigabit adapter!

* Just to double check - if you would go to the Device Manager do you see something like this ?
!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0jZoM66iIXx0rXEdmDMZX31JJCJBPl9EcONxRnBhed-KHPedgNdM1YkCgGA-R9BhPg==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/549000/gigabit_win7.png)

* Is there another entry with an exclamation mark or anything like that?

* If not, can you try unplugging the device and replugging it - does that make Windows detect the device ?

Once we have this information we can suggest next steps!

Regards,
Lampros


#3

Well, there is the first problem. I was looking for the device under USB controllers. The ASIX AX88178 USB2.0 to Gigabit Eternet Adapter does show in Device Manager under Network Adapers.


#4

When I run the Windows Troubleshooter for Inernet Connections it returns:
“Problems found. There may be a problem with the driver for the Local Area Connection 2 adapter”. There is also an Intel 8425DC Gigabit Network COnnection that I am trying to replce with the USB adapter. However, a double click on the ASIX adapter in Device Manager shows the status as “Working properly”


#5

Hi Steve,

As there are 2 lights on the adapter (green and yellow) can you say which one is that stays solid ?

Are we correct to assume that you are not actually using the Intel 8425DC Gigabit Network ? ( i.e. no cable connected there )

Have you set the correct IP settings for your ASIX AX88178 USB2.0 to Gigabit Ethernet Adapter ?

It sounds like the driver for the ASIX adapter has been installed correctly- can you get us a screenshot of the troubleshooter error that you see ?

Regards,
Lampros


#6

The green one stays solid.

There is no cable attached to the Intel network card

The default setting installed with the software is to detect IP address automatically and I have not changed that.

I am familiar with the procedure for screenshot capture. Please advise and I will send you the troubleshooter screen shot

In Control Panel>Network & Internet>Network connections> COnnection Status IPv4 and IPv6 Connectivity both show “Not Connected”

In Troubleshooter it says “Windows couldn’t automatically bind the IP protocol stack to the network adapter”

Thanks for your help Lampros.


#7

Hi Steve.

It sounds like the drivers aren’t installed correctly after all. Please try this:

  1. Go to Device Manager, right click on the ASIX AX88178 USB2.0 to Gigabit Ethernet Adapter and click ‘Uninstall’ - when asked make sure to tick ‘Delete the driver software for this device’.

  2. Unplug the device and reboot Windows.

  3. Connect to the internet using your Intel 8425DC Gigabit Network - make sure your internet is working

  4. Plug in the ASIX - Windows should start looking for drivers for the ASIX adapter on Windows Update

After a few minutes the driver should be installed and the device should be operational - move the cable to the ASIX adapter - does the internet work ? Do you still get the “Windows couldn’t automatically bind the IP protocol stack to the network adapter” error?

Thank you for your patience while troubleshooting this issue!

Regards,
Lampros


#8

Sounds great, except the Intel board is non-functional - hence the need for the ASIX adapter, I’m on my laptop in front of my desktop machine.

Can you offer a link to download the most current driver and I will install from media?


#9

Hi Steve,
Sorry about that I should have thought of that in advance!

You can get the driver from here.

Regards,
Lampros


#10

Hi Lampros. Deleted the old driver. Got the new driver downloaded and copied to the desktop machine. Now the computer will not recognize the ASIX when I plug it in… Windows also cannot find the device to install the driver manually.

This was supposed to be the “easy” solution" I could have bought and installed a new card a week ago. This is very disappointing.


#11

Hi Steve,

I’m very sorry the root problem (and solution) here hasn’t been obvious. ASIX’s drivers work on Win7 64-bit and don’t normally have the problems you’re experiencing. So something is clearly wrong, and we need to figure out what’s different here.

Rather than more back and forth, would you be willing to do two things:

  1. Double-check by re-installing the ASIX drivers. Please use this direct link: http://www.asix.com.tw/FrootAttach/dr… Note that the setup.exe program inside is both an installer and uninstaller - if you have drivers installed, it will uninstall and then complete. If you see that, please run the setup.exe program to install again.

  2. With these drivers now installed, can you please export your system information, so we can see what drivers are getting matched to the adapter, and what other software might be conflicting. Here’s how: http://plugable.com/support/msinfo32/

I know each of these steps requires a round-trip with a USB flash device, since you don’t have a working network on the machine - sorry it’s a hassle.

With this information, we hope to hone in on what’s going wrong on the system. It’s good to do this now, as the problem you’re having may be something generally affecting all network devices – you may continue to have troubles even with other devices.

Thanks for emailing that system log to support@plugable.com. And thanks for your patience here - we never like anything to drag out to a week like this!

Bernie


#12

I returned the device. This form of support is worse than nothing.


#13

Hi Steve - I’m very sorry. It’s understandable you’re disappointed. We’re frustrated too – I expect this was a solvable problem, and we didn’t get there fast enough.

We use Amazon exclusively, partly because returns are handled by them and are no-hassle. You might get a follow-up email from us. If Amazon is slow in any way in getting the refund, please just email support@plugable.com.


#14

I see mine in device manager np, but the cd for the driver installation won’t work at all.


#15

Don’s issue was something that had gone wrong with Windows XP’s msiexec, that was fixed by a Microsoft Knowledge Base article. Here’s the details: http://support.plugable.com/plugable/…


#16

You are being irrational and have given up far too easily. Installing drivers in Windows can often be a hassle. Besides, you already know that the similar old adapter doesn’t work. This is a strong hint that there’s drivers’ issues, in general.

The drivers for the old adapter are likely causing the problems. Haven’t you wondered why it doesn’t work in the first place ?!! Its hardware is likely to be functional and only its driver is causing the problems. You have no way to find out what’s really the problem until you do the following:

In Device Manager, delete the driver for the old adapter and choose the option to also delete the driver files. Do the same for this new adapter. Make sure the old adapter is NOT plugged into your PC. Reboot.

Install the new adapter according to the instructions. The new adapter may have to be plugged into your PC when you install the driver. OR NOT ! Read and follow the installation directions to know whether or not to have the adapter plugged in while installing its driver.


#17

Hi Raoul,

Thanks for posting, enjoy your holidays!

Jerome,
Plugable Technologies


#18