USB Docking station with USB sharing switch creates wake issue

Hello, I recently purchased the Plugable USB 3.0 Universal laptop docking station along with the Plugable USB 3.0 Sharing switch. I have 2 laptops connected to the docking station via the toggle switch and then dual monitors. I keep the laptops in a vertical storage holder with the tops closed. Everything works perfect when switching between the laptops.

However, I run into issues when the laptop that I am not using at that particular time goes into sleep mode. If i switch using the toggle from my active laptop over to the laptop that is in sleep mode, the laptop will not wake up when I move the wireless mouse or press the wireless keyboard. I have to open the laptop and press the power button in order to get the laptop to wake up.
I will add that this only happens when the laptop that is connected to the switch port I am not using goes into sleep mode. If the laptop that is connected to the active port goes into sleep mode, I am able to wake it with the mouse and keyboard. This only occurs if the laptop connected to the inactive port goes to sleep and I have to switch over to that inactive port.

Any Ideas what may be the issue. I have tried all the power management settings that can be found out on the wed with no success.


Hi Craig,

Thanks for posting!

Unfortunately, this may not be something that we will be able to resolve in terms of configuration or a settings change. The reason is that we’ve seen wireless mice and keyboard from Logitech for example do not support being connected to devices like a KVM switch, as the inability to wake from sleep is a potential symptom:

In the meantime, while I understand that you mentioned you’ve tried changing power management settings, have you tried turning off USB Selective Suspend? This can sometimes cause problems with the waking behavior with our devices, so we’ll want to disable this option to see if that helps. To do so, please follow these steps:

  1. Right-click on the Start Button and select Power Options
  2. Click on Additional power settings under the “Related settings” option on the right-hand side of the window
  3. For the active power plan setting (Balanced), click Change plan settings
  4. Click on Change advanced power settings
  5. Scroll down in the list of items and expand the USB Settings option, and then expand the USB Selective Suspend setting
  6. Change the settings for both “On Battery” and “Plugged in” to Disabled
  7. Click the Apply button, and then click the OK button
  8. Close the remaining windows and restart the system and test the behavior again

Thank you!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.