USB devices not detected in M1 Max

Just wondering if anyone has this issue.
The hub worked perfectly with my intel MacBook pro with thunderbolt 3.
However, after I switched to this new M1 Max Macbook Pro, most of the devices connected to this hub can no longer be detected.
There’s no error message or anything. It simply doesn’t seem to be picked up by the system.
Unplugging it from the hub, and plug it directly to the laptop works fine.
Bringing it back to the intel MacBook pro, it works fine too.
Any ideas? Thank you!


Thanks for contacting Plugable support! I’m sorry to hear about this issue through your Plugable HUB, but I’d be happy to help. To clarify, could you please provide the Amazon Order ID associated with your Plugable device?

This information helps me understand the specific model of Plugable product you have and confirms purchase information and warranty status in case it may be needed later.

I’d like to request some logs from your system to investigate further. Could you please keep the Plugable adapter connected to your system (with the non-working displays still attached), then navigate to our PlugDebug tool ( and follow the instructions there?

Thanks for giving us a chance to help!

Omar D.
Plugable Technologies

Hi OmarD,

I have sent a reply email to your support email with all the requested files. Could you please confirm that was sent through? Thank you!

Hello Kevin,

I’ve received your message!

We will continue support directly.

Thank you for allowing us to help.

Omar D.
Plugable Technologies

Hi Omar,

Thank you for your reply.

And Thank you for your thorough explanation of how I could diagnose the problem.

While I am testing on either machines with different varieties of connections, I came across an article stating that it could be a problem with Apple OSX

Apparently if my devices are connected to a USB Hub, it will NOT work!

With further testing,

I connected TB4 hub ONLY to a wired USB keyboard, it will work on INTEL Mac OSX running 12.0.1, but it will not work on M1 Mac OSX running 12.0.1.

I tried different devices on INTEL machine, and some of it won’t work either.

I tried my old setup with everything connected, and of course it will not work on either INTEL or M1 silicon.

I do believe it is Apple’s OSX problem. And I will wait for their update. Meanwhile, if you have any other info that can be helpful, please do not hesitate to share. and I will keep you updated once there’s any good news!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Post update:

The issue was solved by replacing the unit for the customer.

[Discourse post]

Omar D.
Plugable Technologies