USB-C port on my XPS13 9350 not working


#1

Just bought the Plugable USB-C dock. On Friday, it worked great with my XPS 13 9350 and a Dell U2715H monitor, just using the HDMI to HDMI cable in the 4K port of the dock. This morning, my laptop now shows a USB error (The last USB device you connected malfunctioned, and Windows does not recognize it). Tried a USB-C to DisplayPort cable, thus bypassing the dock. No luck either, so I am guess my laptop’s USB-C port is not working? Any suggestions?


#2

Hi Jeff,

Thanks for emailing! We’re happy to help. Thanks for trying the USB-C to DP cable, which confirms something is going on with the USB-C port on the laptop.

The first thing we’d recommend is a reboot. There is firmware in the laptop controlling the alternate mode negotiation, and we’ve seen laptops get in a bad state and need a reboot.

If that doesn’t work, we’ll next want to figure out if it’s just the 4K screen (alternate mode display) not working, or if all USB functionality is failing. Thanks for attaching the dock and see if anything (network, audio, other USB devices) is working and letting us know what functions are succeeding or failing.

Thanks for your patience while we work to help!
Bernie


#3

thanks Bernie for the quick response. As I expected, nothing with your dock, but my XPS 13 9350 had a bad USB-C port thing. I called Dell support, they were surprisingly quick in taking over my machine remotely, uploading a ton of different drivers and fix it tools, and then everything is working well again. Only a few biz days on my dock so far, too early to write a review, but my initial take is that it will be a great product.


#4

Hi Jeff,

That’s great news that a Dell software update resolved the issue! Thanks for being so proactive in working towards a solution.

If anything else comes up, just let us know if we can help in any way. Thanks for mentioning the potential review - that would be very kind, and your experiences would be very valuable to others.

Thank you!
Bernie


#5