USB-C Docking Station - 2 out of 3 displays work

Using USB-C Docking station with Lenovo 720 with Windows 10 Pro. 2 hdmi cables to external monitors
Docking station worked well for first couple of days except for having to reconnect USB C cable to computer after waking from sleep.
Now on booting computer screens flash on and off, have to disconnect each hdmi cable from hub, power cable from hub and reconnect one by one to get 1 out of 2 of the external drives working (the 2k socket)

Right clicking on desktop to Windows Display settings - Windows only detects 2 screens (Laptop + 1 external)
Also on desktop context menu Intel Graphics Setting detects all 3 screens.
3rd monitor remains blank and reports “no signal”

Start up windows appear off screen (above external monitor) and have to be moved into view.

Hi @vicsteadman,

Thanks for posting!

Based off your description of the issue, I’d like to request some logs from your computer to best investigate further. Could you please keep the Plugable dock connected (with everything still connected), then navigate to our PlugDebug tool and follow the instructions there?

Please send this file to us directly at support@plugable.com and include “Ticket #320797” in the subject line.

Thanks for giving us a chance to help!

Mitchell

Hi Vic,

Thanks for sending over those log files. Let’s start with the missing third display issue.

Looking through the log contents, I see that you’re driving a 2560x1440 display via the “HDMI 2K” port on the dock. Please note that along with the “HDMI 4K” output (supporting up to 4K 30Hz) the Plugable UD-ULTCDL supports either:

  • 1 additional monitor at 2560x1440 at 50Hz refresh rate, or
  • 2 additional monitors at 1920x1080 at 60Hz refresh rate

Are you able to connect this ViewSonic 1440p monitor directly to the HDMI 4K port on the dock instead? If your other two monitors are 1080p displays, then you can connect them to the HDMI 2K and DVI ports on the dock.

I hope this helps clarify.

Mitchell

Thank you Mitchell
I can confirm that I currently have:

Viewsonic 2560 x 1440 connected to the 2K socket
HannsG 1920 x 1080 connected to the 4K socket

In this configuration everything is stable.

If I switch the 2 hdmi terminals it returns to the original problem:

The viewsonic (connected to 4K socket) is blank
The laptop and the HannsG (now on 2K socket) both flash on and off. With the Windows Display manager open, on the HannsG monitor, I can see the system is flashing between 3 monitors detected and 2 monitors detected. But it does not stabilise on either and continues to flash on and off.

I have just rerun the debug tool with the monitors connected in the faulty configuration with the Viewsonic monitor connected to the 4k socket. I will sent that by email.

Regards

Vic

Thanks for sending over those second set of logs, Vic.

Looking through this second set of logs, interestingly, I am indeed seeing that your ViewSonic monitor is now connected to the HDMI 4K port, and the HannsG monitor is now connected to the HDMI 2K port. That said, both appear to be working properly (which obviously is not what you report).

Let’s proceed by making sure that the make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 9.4 M0 DisplayLink software (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+9.4+M0.exe)
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Please let me know if this helps at all.

Thanks!

Mitchell

Thank you Mitchell.
I have followed your instructions. I had previously installed the 9.2 DisplayLink software, now replaced by 9.4 version.
Unfortunately the problem remains when the Viewsonic monitor is connected to the 4k output, with or without a 3rd monitor.
With the Viewsonic monitor connected to the 4G terminal, nothing connected to the 2G terminal, nothing connected to the DVI terminal - the built in laptop monitor cycles between desktop and blank, the external monitor is blank.
If I then connect the HannsG monitor to the 2K outlet it cycles between desktop with icons and desktop without icons. The taskbar stays on.

If I switch the 2 hdmi screens all is stable with
Laptop screen running at 1920 x 1080
Viewsonic connected to 2K running at 2560 x 1440
HannsG connected to 4k running at 1920 x 1080

Regards

Vic

Sorry to hear that wasn’t of any help.

Looking further into the user manual for this ViewSonic monitor, I’m seeing that the manufacturer actually doesn’t support 2560x1440 resolution via the HDMI connection on Windows hosts – only the DVI and DisplayPort inputs support 1440p.

I wonder if this has anything to do with this problem. What if you connect the ViewSonic monitor to the “HDMI 4K” port on the dock, then drop the resolution of the display to 1920x1080 in your Windows Display settings (Right-click on Desktop, select Display settings)?

Thank you!

Mitchell

Thank you once again Mitchell. If I connect the ViewSonic monitor to the 4k output it is not stable enough to select the settings window so I cannot adjust the resolution in that configuration.
I have tried connecting this monitor via the dvi connection without success - blank screen.
Using analogue cable via the supplied dvi adaptor does work but with a colour cast that suggests one of the colour channels is missing.

So it looks like the problem is incompatibility between the ViewSonic monitor and the hub and the solution is to replace the monitor.

Vic

Thanks for trying, although understood that you can’t change the resolution when the ViewSonic monitor is connected.

The ViewSonic monitor likely doesn’t work through the DVI port on the dock because the DVI port on the dock is a single link DVI port. This monitor requires a dual link DVI connection to support 1440p.

A workaround for the moment would be to keep this ViewSonic monitor connected to the “HDMI 2K” port, but that does mean that you cannot use the DVI port on the dock.

While I understand this may not be possible, do you have another USB-C computer available in which you could connect to the dock? This would help us understand if this ViewSonic display issue through the HDMI 4K port on the dock occurs external to the computer, but I understand not everyone has a spare USB-C system.

Thanks!

Mitchell

Good morning Mitchell,

Thank you for your continued support.
I attempted to connect the hub to a HP EliteBook 840 G4 but without success. Neither monitor was detected when connected to the 4k port on the hub.

regards

Vic

Thanks for trying that.

Unfortunately, while the HP EliteBook 840 G4 system has a USB-C port, it supports data transfer only. It does not support DisplayPort over USB-C or Power Delivery for charging, and we actually call out this specific model as an incompatible computer on our compatibility chart. As a result, what you observed is expected behavior.

Mitchell

Good information thanks for sharing
vmware