USB-C 4K Triple Display Docking Station - Not Functioning Properly

Hi,

I have a “USB-C 4K Triple Display Docking Station with Charging Support for Specific USB-C and Thunderbolt 3 Windows and Mac Systems”, which is causing me huge issues. It seems to overload, mostly when I am in an online meeting. I will be in the middle of presenting something, when all of a sudden my screens flash and then freeze or partially freeze. At the very least I have to reshare my screen, but sometimes all of my screens freeze and I cannot correct the issue until I restart my computer and the docking station. This issue seems to be getting worse, if anything, so I either need to resolve it by fixing the problem or replacing the dock. The model is UD-ULTC4K.

Thank you in advance.

Hi Michael,

Thanks for reaching out to Plugable support! I’d be happy to help with that docking station.

The first steps we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

Windows OS:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.

  2. Uninstall any and all software with ’ DisplayLink ’ in the title that is present from within the Control Panel -> Programs and Features . Don’t worry if these entries are not present or if the process does not work, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool (https://www.displaylink.com/downloads/file?d=64)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 10.1 M0 DisplayLink software (https://www.displaylink.com/downloads/windows)

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

For macOS 10.15 and up :

For macOS 10.14 to 10.15 :

If these steps help, great! If not, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 337840’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.