USB-C 4K not charging laptop

The docking station is not charging my hp spectre 360x laptop. I know the usb-c will charge the laptop as it worked with another docking station.

My laptop shows it is “plugged in” but the battery drains.

I’m having the same issue with an AZUS SenBook S series. Most of the time the dock charges the battery. But several time a week, it will disconnect then reconnect and leave the laptop to run on the battery. I’ve tried cycling power on the power adapter and that fixes it about 70% of the time. Other times, I turn everything off and let it sit for a while (30 minutes). Often that corrects the problem. But the problem always returns. Pretty sure it’s a hardware issue in the power adapter or power section inside the dock.

@jwood

Sorry to hear about this issue. Depending on the Spectre you have, this may be not unexpected as not all Spectre systems can support charging from a 60 watt charging dock like ours.

“I know the usb-c will charge the laptop as it worked with another docking station.”
Do you know what the other dock model was? It’s possible it offered more power than ours.

“My laptop shows it is “plugged in” but the battery drains.”
Does it say “Plugged in, charging” or “Plugged in, not charging”?

@jtmartin61

It’s possible there is an issue with the dock, but more likely, there may be some slight incompatibilities between your ASUS and our dock. We’ve encountered issues like this before where replacement docks that we’ve pretested here (and thus ruling out a hardware fault) haven’t resolved the issue.

Since your issue is almost certainly due to different reasons than the original poster for this support thread, let’s have you open a separate support ticket. Just shoot us an email over to support@plugable.com and let us know which exact ASUS ZenBook S model you have and we’ll go from there.

Thanks everyone!
Joshua Henry
Senior Engineer
Plugable Technologies

It says plugged in charging. Even with the laptop in sleep mode the battery drains even though it says it is charging.

and now it is charging…without me doing anything…possibly a faulty cable?

Thanks for the updates.

A defective cable can certainly contribute to dock power or stability issues, but it wouldn’t explain the situation for the battery draining despite saying plugged in and charging. That issue could be a compatibility problem, or the dock itself may have a problem. To help narrow down what it could be, we have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Thanks!
Josh

Sending the email with the file shortly. The laptop has stopped charging again.