USB-C 4K lost functionality to connected 4K monitor and USB devices

I went to connect my MacBook pro to the Plugable USB-C 4K docking station and found I no longer had video on the connected 4k apple monitor, (including power and functionality to wired keyboard and mouse connected to the monitor); B&W speakers connected via USB to the hub not working. Tried connecting mouse and keyboard to the hub’s USB ports without success (note: the wired mouse lights up red - but does nothing to the cursor).


External hard drive connects fine to the hub and works perfectly.
Ethernet connects hub to modem and works perfectly.
Phone and other devices connected via USB cable to hub charge perfectly.

Keyboard, mouse and monitor work perfectly when connected directly to the laptop (ie. cutting the hub out of the loop), so they aren’t faulty.

Have tried all of the suggested remedies of disconnecting everything and reconnecting, utilising different ports on the hub, swapping USB-C cables etc. all without success. This item is less than 6 months old, and hasn’t really been used at all for the past 3 months!

What can be done to get this fixed please?


Thanks for contacting us! Sorry to hear about this issue. I’d be happy to help.

I’ve gone ahead and replied to your direct email that you’d sent to us with a couple of recommendations, but we may need to replace this dock under warranty. I’ve provided instructions if that ends up being the case. If you’ve not received my email please do let me know.

Thanks for giving us a chance to help!

Best wishes,
Joshua Henry
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.