USB-C 4K Dock Dropping all connections in multiple Dell laptops

Hello,
We are currently having issues with the docks dropping all connections. When I say all connections, I mean network, connected monitors, and keyboard and mouse. It is almost like the dock resets. I noticed this happens when using both monitors. I have tried resetting the dock, uninstalling and reinstalling drivers, and trying on other machines. Still same issues. The issues are intermittent, but happen on any of our Dell model (the only brand we have) laptops. Any help would be appreciated, Thanks!

Hi Tim,

Thank you for contacting us, I am sorry this is not working as expected and I am happy to help!

Just to verify, is this issue affecting multiple docking stations used with multiple computers?

Are all of the docking stations the same model UD-ULTC4K USB-C Triple 4K Display Docking Station ( https://plugable.com/products/ud-ultc4k )?

When these disconnections occur is there any specific software being used with on external displays connected to the docking station, for example streaming software like Microsoft Teams or Google Meet, or 2D or 3D graphics software? If there is a corrolation between the software running and the disconnections then most likely the issue is caused by out of date or miss-matched drivers. Dell has not yet started providing drivers for the latest release of Windows 10 ( version 21H1 ) and has many out of date drivers on their website for previous versions of Windows 10 that may be causing connectivity issues.

Based on your description of the behavior, we can get some log files from one of the affected computers to check for updates or out of date software.

If you would, please keep the dock connected to the computer with monitor(s) connected tot he docking station (even though one may not be working) and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line ‘Ticket #355632 - Attention Pat’ as this will allow us to examine some log files from your system to help determine the next steps.

Thank you,

Pat
Plugable Technology
support@plugable.com

Hi Pat,
Thank you for your quick response! The docks we have are the one I mentioned and the USB3 dock. Both have the issues. Ill give you what happened to me today as an example. I was on a teams video meeting on my laptop display and had notepad ++ on one of the other monitors. THE MOMENT I STARTED TYPING I started having issues. I will provide the logs as requested, but do you need the issue to be actively happening when I run it?

Hi,

Thank you for replying back, the issue does not need to be actively reproducing when the log files are gathered. I look forward to your reply email with the log file attached and we can go from there.

Thank you,

Pat
Plugable Technology
support@plugable.com

Thank you! I will get on that right now.
Things you should know now:

  • I have now updates to Windows 10 21H1 from Microsoft.
  • I contacted Dell Support and they cant find anything after doing the update with them on the phone.
  • I was thinking that maybe this is a global usb-c driver issue. After reading through a good number of threads, it does seem to be the common denominator. Almost like its a Windows issue. I also wonder if it is only Intel supported boards or if AMD supported boards are having the issue.

I just wanted to post this just in case someone was following having the same issue. Ill get that email over to you ASAP!

I found the help article. https://www.dell.com/community/Windows-10/Dell-D6000-Windows-10-DisplayLink-drivers-crashing-user-mode/td-p/7639429