USB-BT4LE stoped connecting and just scans on Kubuntu 23.04

Late last year I ordered and received the Plugable BT4LE to connect a new Keychron K4A3 bluetooth keyboard to my Kubuntu dekstop. It worked well at first, with a few random disconnects, with slow reconnect. Mostly happening, around the computers sleep mode and when trying to awaken the system.

Flash forward and most of this year (2023) I have had to connect my keybaord via a USBC cable. Kubunu sees the adapter, but it just scans. Never finding anything to connect too. I know its is not the keyboard as I can connect it just fine to my laptop with built in bluetooth (also running Kubuntu 23.04). And I can even see my keyboard on my cell phones blutetooth discovery list.

I bought this adapter speficily for use with linux boxes, as at the time the discription on Amazon said it worked with linux distros. And 3rd party review pages verified it did.

Reviewing some of the support topics here, and going back to the Amazon link I see it has changed, and states that, linux is no longer considered a supported OS.

I also see that the previous advice is to update bluez. But bluez is native in kernel 2.6 , which Kubuntu 23.04 uses.

Is there any other trains of thought on what might be going on with the adapter and /or the driver(s)?

Thanks in advance.


Thank you for your message.

The reason our support considerations around Linux have changed, is because we have continually encountered issues where Linux distros, and more often the BlueZ project, are breaking Bluetooth functionality.

The driver for the USB-BT4LE is in the Linux kernel. BlueZ is a package.

In our experience, following the process noted here will generally get a functioning version of BlueZ installed:

Since we do not have direct control over these third-party projects (kernel, distros, BlueZ), and breaking issues can (and often do) happen without being able to resolve the issue, we have been disclaiming Linux support for some time now.

If you would like further review of your purchase, please reach out to us directly via email at with your order information.

I hope that this helps.

Thank your for the reply. I completely understand the reason for Plugable’s change on support for linux distros. I am did not intent to sound… angry or upset, over it.

I have been reading further on bluez, and I do see that difference between the drivers (installed with the kernel) and the package. Which is not installed by default. I’m guessing its because the distro is wanting you to use their desktop environment UI. Which is where the issue seems to be happening.

I will try the package install you have linked, and come back with the results.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.