USB-AUDIO adapter microphone port on Raspberry Pi


#1

I’ve had no success with audio input using the USB-AUDIO adapter on the Raspberry Pi (latest model, B+). I appreciate the guidance (provided elsewhere on your site) re: audio output, but can you do the same for use of the microphone port?


#2

Hi Mark,

Thank you for contacting us about using the microphone port on the USB-AUDIO device. I can help with that.

If you have followed the instructions on this page:

http://plugable.com/2014/11/06/how-to…

you should already be set up for both audio input and output through the USB-AUDIO device.

This page

http://www.g7smy.co.uk/?p=283

has great instructions for setting up the mike and testing it by making a recording. A few points to mention: If you have correctly edited the alsa.base.conf file, the USB audio device will be set up as device 0. You can check this by issuing this command:

aplay -l (lower-case letter L)

It should report this in the second line:

card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]

if it does, you can follow the rest of the instructions, using 0 for the device and it should work.

Please let me know how it goes.

David
Plugable Support


#3

Thanks for the quick reply. I was delayed in responding because I chose to start with a fresh copy Raspbian Wheezy.

aplay works fine when the output device is defaulted or when -D plughw:0 is specified. And there’s no complaint from arecord when -D plughw:0 is specified or the default is taken. But when I try to play the audio file generated by arecord, there is no audio.

I also used alsactl to see that the mic was not muted and that it’s gain was set to 60.

I should also point out that I’ve tested the microphone on a PC and it works fine.

Here are the results that you and/or Patrick asked for:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

===============================
alsa-base.conf

autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe –ignore-install snd &install snd-rawmidi /sbin/modprobe –ignore-install snd-rawmidi &install snd-emu10k1 /sbin/modprobe –ignore-install snd-emu10k1 Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

#options snd-usb-audio index=-2
options snd-usb-audio index=0
options snd_bcm2835 index=1

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-


#4

Hi Mark,

The output from aplay looks good. One thing Patric suggested we investigate is the type of connector on the mike. If you have a mono connector like the one in the photo I attached, it won’t work.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1145383/IMG_0513_inline.JPG?1421873118)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1145383/IMG_0513.JPG?1421873118)

You would need to get a mono to stereo adapter like this one:

http://www.amazon.com/C2G-Cables-4063…

I hope this is the issue. Otherwise, we can do some more troubleshooting.

David


#5

Bingo! I had no idea that a stereo mic plug would be needed.

But I did find an old mic I had with the stereo plug and it worked just fine. I’ll order a mono-to-stereo adapter for future use.

Thanks to you and to Patrick for your help.


#6

Great! I’m glad it worked!


#7