USB A 3.0 Ports Will Not Work


my Plugable USB-C Triple Display Docking station USB A 3.0 Ports do not function properly. I noticed this issue when I tried to connect my Blue Yeti X and my Logitech Pro X headset. It provides power to them but I can neither hear music through the headset or record with the microphone. They are also not recognizing any USB storage devices.

When I plug any of these devices directly to my HP Spectre x360 13-ac0XX they function properly. When I tried troubling shooting by unplugging everything and power cycling I actually ran into more problems. The HDMI 2k port stop functioning. After troubling shooting DisplayPort issue by uninstalling the DisplayPort drivers, updating to the newest version, restarting the machine, power cycling the Plugable, and reconnected back to my laptop, both HDMI ports were functioning properly again but the USB A 3.0 ports still are not functioning properly.

I am using the USB-C to USB-C cable that was provided with the purchase of the dock.

My amazon order number is Order# removed personal information-Josh, Plugable Technologies


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock with your devices attached into your computer, then go to this page and follow the instructions there:

Please note I removed the Amazon Order ID from your post since this is personal information. If we need further personal information later, we’ll do so via a private email to you.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.