USB 3 Gigabit adapter not working via powered hub


#1

My Pluggable USB 3 Gigabit adapter has been working very well via my Anker 9-port USB 3 powered hub for over a year, and recently it stopped working, even if it is the only device on the hub. With the Pluggable connected directly to my MacBook Pro Retina 13" running OSX 10.11.12 it works fine however. All other devices plugged into the hub work fine. I would have assumed it is a power related issue, but it has been working for a long time previously and can’t see why the hub would have changed?


#2

Sorry to hear about this.

Does moving our USB3-E1000 to a different USB port on the Anker hub make any difference?

Also have you tried resetting the hub (unplug it from all USB and power then reconnect power first, USB last)?

Thanks!


#3

Hi Josh. Moving to a different port makes no difference, and neither does resetting the hub. Contacted Anker support and they advised it sounds like a fault with the hub, so it is being replaced and hopefully that will resolve the issue. Many thanks.


#4

Just to update on this, new hub now received and working perfectly :slight_smile: Many thanks for the support!


#5

Glad to hear it worked out!


#6