USB 3 external drive doesn't work at end of this cable

The drive is a Transend JetStore and it works fine plugged directly to the machine. I also have a USB SSD adapter that I can plug in SSD’s into USB and it has the same problem down this cable.
This is all off USB 3.0 Server 2019 OS. SuperMicro motherboard. I’ve tried this with and without the additional power adapter for the cable. Odd thing is I can plug the device in and it shows up for 2-3 seconds then disappears.

Hello Bert,

Thanks for reaching out to us! I do apologize for the trouble with the extension cable. Was this a recent Amazon order? May I get your Amazon order number please? If you would, please write into us directly at: support@plugable.com to provide this sensitive information and use ticket #281530 as the subject.

Thank you, and I look forward to hearing back from you!

Kevin
Plugable Support

So sorry for slow reply. I fixed this or came up with a workaround. I had three 10 ft usb cables in addition to this cable and when I tried 2 of those cables the device worked fine but after adding a third cable it stopped working. Fortunately I had a USB3 PCI device so I installed it and it worked at 30 ft. Evidently the USB on the Supermicro mother board is weak. I do however question the efficacy of the additional power adapter that comes with your 30 ft USB 3 cables. Shouldn’t it remedy just this sort of thing?

Hello Bert,

Thanks again for the reply! I do apologize for any trouble in this. I’d like to ask, are these other extension cables ours, or another manufacturer? To make sure I correctly understand, there was at least 60 feet of cabling total?

With respect, we haven’t tested out this specific scenario and can’t guarantee exact operation quality. Again, with respect, we are unable to account for other extension cables and any compatibility issues. There could be conflicts with different chipsets, and that is quite a long distance for the power and signal to travel.

So currently, you have found a solution to the issue by lowering the cable length? Again, I do apologize for the trouble in this. Please let me know if you have any further questions.

Thank you,

Kevin
Plugable Support
support@plugable.com

No not 60. Initially it failed with your 30 foot cable so then I used the other three cables as a distance test. I felt like that’s what the problem was so I hooked 2 of those together for 20 feet and it worked then attached the third for thirty feet and it failed with the other manufacturers cable so I figured it was the motherboard USB port and not cables at that point. I’m hooked up with your 30ft cable and functioning fine with the PCI USB card.

Hello Bert,

Thanks for getting back to me! Ah, I see, my mistake. Thanks for clarifying. I do apologize for the trouble with our cable initially. Ok, so it sounds like you’ve found a solution with a PCI USB card? I hope this is a good solution. I want to make sure that you are happy with our product. Is the drive performing normally now? Please let me know if there is anything I can do to help.

Thank you,

Kevin
Plugable Support
support@plugable.com