USB 3 E-1000 works fine then loses connection


#1

I am using the USB3 E-1000 with an acer revo which suffered damge during a lightning strike. Fortunately only the ethernet port was lost hence my purchase of the E1000. My problem is this. The device works fine for varying amounts of time and then suddenly I lose connectivity to the network. On checking the adapter the green activity light is flickering constantly as is the corresponding port activity light on the switch ti is connected to. I have to reboot to get connectivity back. any ideas?


#2

Me too. I have the USB2 version and it works fine. Tried upgrading to USB3 and it can’t hold a connection. My only thought is to return this since I see this question hasn’t been addressed and it was posted 3 months ago.


#3

Hi Bob - Sorry, we missed providing an update on Ken’s case 3 months ago. Ken moved some of his other devices to other USB ports and solved the loss of connection problem. We’re not certain why that solved it, but usually that points to a USB power problem.

In your case, where an adapter works fine on USB 2.0 but not on USB 3.0, it’s usually an issue with driver versions (although there are some off-brand older USB 3.0 host controllers like etron that have problems that persist even with the latest drivers).

For detailed help, you could run our debug utility (http://plugable.com/support/plugdebug) and email the .zip file it generates to support@ plugable.com

That’ll let us see what driver versions, etc. might be out of date. Thanks for your patience!
Bernie


#4

Having the same issue.


#5

Also, when I plug in the adapter to the usb 3.0 it clocks for a while and then … nothing. I went to my mother board manufacturer and updated the usb 3.0 drivers, so I have the latest drivers. I also used the latest drivers provided on this website. I am at a loss. I do not know what to do next.


#6

Me too! same problem. Wish I’d read these posts before ordering mine. Just got my USB 3 adapter and it keeps losing connectivity. I use Macbook Pro with Yosemite 10.10.1. I have installed plugable’s driver, it arrived today, works smoothly for a bit then loses connectivity. I have to remove from USB slot and re-insert for it to return to funtionality. I might return it and buy another one from elsewhere.


#7

Note: Plugable replaced mine with another identical model back when I reported my problem (7 months ago). The replacement has worked fine since. I guess that first one was just defective.


#8

Sure. I may probably have to return mine too. Thank you.


#9

Hello all,

If you have any other issues with your Ethernet adapter, please contact us at support@plugable.com and I will be happy to assist.

Kind regards,
Patric
Plugable Technologies


#10