USB 3.0 with 2K display works, but is sluggish and some applications have Error 87

Is there a way to fix LoadLibrary Error 87 and sluggish screen?
With Your driver active i get this error on most programs saying parameters are incorrect. Is there a way to fix With out?

Thanks for reaching out to Plugable support! I’d be happy to help with that display adaptor.

The first steps we’ll want to take is to make sure that the software used by the display adaptor is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the display adaptor from the system (this is important so the unit resets). Please keep it disconnected until the last step.

  2. Uninstall any and all software with ’ DisplayLink ’ in the title that is present from within the Control Panel -> Programs and Features . Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool. (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe)

  4. Once the Cleaner has been run, reboot (even if not prompted to).

  5. Now download and install the 9.4 M0 DisplayLink software. (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+9.4+M0.exe)

  6. Reattach the display adaptor to your system which will trigger the final portion of the installation.

Hopefully that will get things working for you.

Thank you for giving us a chance to help!

I’ve tried all steps above already. It didn’t work. Error 87 still occurs.

Now, I think you can forget about error 87. I just want to focus about screen lagging. After I have tested it by selecting screen solution from 800 - 1920p, it worked but with the resolution 2560*1440p. it didn’t work. Everything was lagging. How can it fix it?

Thank you for the update.

There are a few things that can produce screen lag depending on if you have wireless mouse and keyboard connected or what software you may be running.

When you have a moment, could you please let us know the following details:

  • Is there a particular program that triggers the lag in the display?

  • Could you post a video of the lag that you see?

  • The model of your Plugable device (located on the product itself, the box, and the quick start guide)

Thank you for your patience and for giving us the chance to help!

I don’t have any wireless connection.

Ans. from Q.1: I surely say that I don’t have it.
Ans. from Q.2: okay, I will record the video to you.
Ans. from Q.3: I brought plugable Usb 3.0 to hdmi 2k 2560x1440 p.

Sorry, this forum cannot upload video file