USB 3.0 transfer cable

I have just received USB 3.0 transfer cable. Everything worked great for about 5 minutes then I got a message “connection lost”. I’ve tried all 3 USB ports on the old computer (I have only one on the new unit) without results. Message now shows “waiting for connection”. Tried shutting down both units and starting over. Help!!

Hello Lee,

Thanks for reaching out to us about this. I’m sorry for the trouble here, and I’d be glad to help you! Are you using the latest version of the software? I would suggest to download and install the latest version of the software from this link: This latest software improves compatibility so I would strongly suggest to install it on both computers, and give both computers a restart. Then, try the connection again after restarting. If that doesn’t get things going, give these steps a try:

  • You mentioned having tried different USB ports, which is great! But, let’s also try swapping the cable ends around as well. This is a pretty basic first step, but it can really make the difference and hopefully get you going.

Another important thing to try, is to run the program as an administrator. You can do this by right clicking the application, and choose, “run as administrator” (The transfer program grants direct access to files, so Windows User Account control may flag it, and keep it from running.)

Finally, if these steps don’t work, let’s try temporarily disabling any antivirus/firewall/security software on both computers. The software can definitely be enabled again, and if the connection works properly, you may need to just add an exception for the Transfer Software to your security program.

I hope this helps! Please let me know what happens.

Thank you,

Product Owner
Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.