USB 3.0 to 4K HDMI no 4K option


#1

Plugged into a Dell 4K monitor. Highest resolution available is 1920x1080.


#2

Hi Andrew,

Thanks for posting. I’d be happy to help with your adapter!

Can you provide some additional detail about your setup? Specifically what type of system and what version of Windows you are using? Can you let us know which specific model Dell monitor you are using? Can you confirm you are using a high speed HDMI 1.4 or better cable to connect the monitor?

Just let us know the additional information when you have a moment and we’ll go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

I’m running Windows 7 Ultimate on a Dell Precision M4600. Monitor is Dell P2815Q. The monitor is limited to 30hz at 4K. Cable is Amazon Basics High Speed HDMI with Ethernet 25 feet long. Monitor type shows generic.


#4

I tried another cable and it worked. Thanks!


#5

Hi Andrew,

Thanks for getting back. I was penning my rely when I saw you latest update pop up. Swapping the cable was going to be my recommendation and was a good call on your part. When pushing that much information you always want to make sure the cable isn’t the cause.

I’m glad everything is working properly now. Please let us know if you need any help in the future!

Thank you,

Bob


#6