Usb 3.0 sharing switch: computer control panels see storage device but it does not show in file explorer

I connect desktop and laptop to B ports USB 3.0 sharing switch, and LEXAR 512 GB SSD drive (my computers are both plug n play) to A port. The drive does not show up on file explorer menu on either computer. Both computers show it in the Control Panel Device Manager (“USB Attached SCSI (UAS) Mass Storage Device”) and Devices andPrinters windows when the appropriate button is lit up.
Device manager indicates drive is working properly. When I plug keyboard into the A port it works on either computer when selected. I bought two of these switches and they both behave the same. Any ideas? Thanks for responding. George Chandler, (email removed by Plugable).

Hi George,

Thanks for posting! I’m sorry to hear that you are experiencing issues with your USB switch. We’ve also reached out via email and we’d like to help.

To start, could you please provide the following information for warranty verification?

Also, we have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

Finally, would it be possible to send us a screenshot of your Disk Management window? Instructions here:

Since this is a public post, all of this information should be sent to ticket you submitted.

Thanks for giving us a chance to help!


Hi George,

Thank you for sending us your log files.

The first steps we’ll want to take is to ensure that the Lexar SSD has a drive letter assigned in Disk Management (general procedure with screenshots):

  1. Make sure that the Lexar SSD is “connected” to your system (even though it’s not showing up in File Explorer)
  2. Right-click on the Start menu (Windows Logo), then select Disk Management
  3. In the Disk Management window, look for a drive that does not have an assigned drive letter (no C:, D:, etc.) and is not labeled as System Reserved.
  4. Right-click the unlabeled drive and choose Change drive letter and paths…
    Note: If the Change drive letter and paths… option is not available, make sure that the drive is Online by right-clicking the disk number and selecting Online
  5. Select the first available drive letter by clicking Add and then click OK

Please let me know if this helps recognize your Lexar SSD in File Explorer. If this does not work or if you run into any problems, could you please send us a screenshot of your Disk Management window?

Additionally, does the Lexar SSD work as expected when directly connected to your computer (not connected to USB switch)?

Thanks for your patience while we work to help!


The drive works fine with both computers when not connected through the switch. When connected thru the switch it appears in the device manager and devices and printers. But it does not appear anywhere in the disk management window. I have no idea how to send you a screen shot.

Hi George,

Thanks for the additional clarification.

Instructions for taking a screenshot of your Disk Management window can be found at the following link under the header “How to take a screenshot”:

Thank you!


here are the disk manager window as well as the Devices and Printers window. You only let me send one image so I’ll send the D&P window in another post. The disk is named workflow D512.

Hi George,

Thanks for getting back to us with those screenshots.

Unfortunately, based on the information we have so far, I’m afraid we’ve quickly exhausted our troubleshooting options. The fact that you’re seeing this issue across two different host computers as well as two different USB 3.0 Sharing Switches (USB3-SWITCH2) indicates towards some kind of incompatibility or conflict with the Lexar SSD. It’s possible that the Lexar SSD is very sensitive to cable length, but there is not much of a workaround here in combination with the switch.

We never want our customers to be stuck with a device that doesn’t work properly for them, so I would be happy to help with a return for a refund. Please simply reach back out to us at with your Amazon Order ID and we would be glad to help with a return for a refund.

I’m sorry we couldn’t be of more help here.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.