USB 3.0 PCI-E problem.


#1

Hi !

I had the same problem and more…

I had a “xHCI Root Hub” not recognized in my Device Manager and it caused problems even on my USB 2.0 ports.

My specific problematic card was the “TECKNET “Eu308d” USB 3.0, 5 ports PCI-E Expansion Card”.

After hours of researches, tens of attempts of different kinds: updates of my Intel DZ77GA-70K motherboard, USB drivers, Windows ans system diagnosis tools and much more, “ORICO “PVU3-5O2I-V1” USB 3.0, 5 ports PCI-E Expansion Card” saved my life !

Marvell USB drivers didn’t worked. Neither Fresco, Prolific, NEC, Renesas or others.

Finally, an attempt with the “http://drive.orico.cc/ORICO-PVU3_Seri…” solved the problem instantly…

In fact, it contains VIA Lab’s USB 3.0 chips host controller drivers THAT WERE NOT INCLUDED with my damn TECKNET USB 3.0 expansion card… That was the real problem origin…

Hope this can help !!!

Good luck.

P. Dauphin
Quebec, Canada


#2

Hi Pascal,

It doesn’t appear that this post is related to any Plugable-brand products, but we’ll leave it here in case it can help others who are researching issues.

Thanks,
Gary


#3