USB 3.0 multi display not working for Dell 3007 WFPI monitor via Surface Pro 3


#1

Surface Pro 3 with docking station with two monitors. First monitor is connected via mini displayport to HDMI cable from docking station to HDMI monitor input. Second monitor is connected via Plugable USB 3.0 multi display adapter plugged into the USB 3.0 port of the docking station to the DVI cable connected to the Dell monitor. First monitor is visible and working fine. However, the Dell monitor connected to the plugable UGA-3000 is black screen. Windows display settings recognize Dell monitor, but no display. Please help.


#2

Hi Justin,

Thanks for posting. I’m sorry the adapter isn’t working as expected. I’d be happy to help. I see you also reached out to us directly via our email support system so I am going to reply here and to your email with the same response…

Thanks for providing the specifications of the monitor you are connecting to the adapter. I looked online and found the specifications of your monitor here:

http://www.dell.com/content/topics/to…

In looking at those specs, your monitor input is a dual-link DVI input which is necessary to drive the monitor at its maximum resolution of 2560 x 1600. Our UGA-3000 adapter is only a single-link DVI output supporting a maximum resolution of 2048 × 1152. In this case I am afraid the adapter will not work to drive your display.

We certainly do not want you stuck with a product you cannot use! All of our products have a 30 day no-hassle return policy and the quickest way to return the product for a full refund would be to use the automated system at amazon.com/returns.

Sorry we couldn’t be of more help.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3