USB 3.0 I/O Card having problems in Windows Server 2008


#1

I am having a problem with my Plugable USB 3.0 PCI-E Card locking up my computer when performing a backup to an external hard drive.

I am running a Dell Server PowerEdge T110 II with MS Windows Server 2008 R2. I installed the card with no problems. I wanted to run backups to an external drive through the USB 3.0 connection. The server sees the card and it seems to work and run fine. I can see the drive with no issues and navigate on the drive. I run into problems when I am running a backup of a large piece of data.

I tested the backup with 3 different types of software programs. I even tried to just copy the folders. I finally wrote a small dos BAT file and ran that to do a disc copy and it still locked up.

Every time I would let it run for an extensive time period, 20 minutes+, the server would lock up and I had to do a hard reset to start it back up. The screen would go black and I could not do anything. I had to hold down the start button for 5 seconds to shut it down.

Finally to eliminate the card I tested the external drive through the USB 2.0 ports onboard and I did not have any issues backing up over 300GB of data. So this means there is an issue with the card.

Has anyone else run into this problem?


#2

Hi John,

Thanks for posting here and for all the great information. I have a couple of questions for you. Can you tell me the make and model of the external drive and enclosure? Is it possible to update the firmware on the external drive enclosure? Can you run your backup with the PCI-E card if you connect to it with a USB2.0 cable?

Also, it may help to update your Renesas drivers, here’s a link:

USB3.0 PCI-E drivers.

I apologize for the inconvenience. Let me know about the answers to these questions and try the updated drivers, we’ll figure out where to go from there.

Thanks,
Jerome.


#3

It is a Seagate GoFlex Desk External Drive, USB 3.0. I don’t believe there is anyway to ugrade the firmware, but I don’t believe that is the issue. The reason being is that I plugged my cord from my drive into my USB 2.0 port and was able to run a complete backup without the server locking up. It did give me a message that it was a 3.0 compatible device and will run at faster speeds, but I just wanted to make sure it is not a drive issue. Also, to let you know, this is a brand new server (only a few months old). It has not had another problem with needing to be restarted other than these problems with the USB 3.0 port.

I cannot run the backup with a 2.0 cable, because my drive only has a 3.0 port on it. I would have to get another backup drive with a 2.0 cord and plug it into my 3.0 USB and see if it works. I will try to do that and let you know.

Are the Renesas drivers the drivers for the plugable PCI card?


#4

Hi John,

Thanks for the quick reply with the extra information. You can connect the Seagate GoFlex Desk External Drive USB 3.0 drive via a USB2.0 cable to a USB 3.0 port and it will work at USB 2.0 speeds. Because USB 3.0 is still maturing, there are still some issues being worked out regarding compatibility among vendors and driver stability. The link is for the Plugable PCI card, you can use the installer to update the driver version to the latest available. Give them a try and let me know how it goes.

Thanks again,
Jerome.


#5

John,

It sounds like you are trying to accomplish the same thing I would like to do. I haven’t purchased the USB 3.0 adapter yet, but I have the T110 II and a GoFlex 3TB USB 3.0 drive. Did the updated drivers for the adapter that Jerome posted work? Have you been able to make it work any other way (such as a different USB 3.0 hard drive)? About using a USB 2.0 cable with this GoFlex, it looks like you can use a cable with a standard micro-B type connector, although I don’t have one to try it out.

Plugable, great job on supporting your products. You look like a small company but have a first-class support structure.

Thanks.


Klint


#6

No, the driver update did not fix the problem. Every time I try and run a backup or any type of extended use, through the USB 3.0 port, the Server stops responding, the screen goes black and I must do a hard reset to reboot it. It does not crash immediately. It crashes after running for several hours through the card. Just at the point I think it is going to work, I check back and the server locks up.

As per the suggestion, I ran another external drive through a 2.0 cable through the USB 3.0 card and the problem continues to occur. I have been running the drive through a standard USB 2.0 port on the server and not having any problems since my last post. So this confirms that it is a problem with the card, in 2.0 and/or 3.0 mode on the server.

At this point there is no solution to the problem that has been found, except not using the USB 3.0 card and just running the backups through the standard 2.0 port.


#7

John,

Thanks for the quick reply, this is just what I need to know. Although, it doesn’t look like there would be any other options because any card I find that lists support for Windows 2008 are using the NEC/Renesas chip. Have you seen any other cards that you think would work? I am actually wondering if it is a problem/incompatibility with the T110 II itself.


Klint


#8

I have not done a lot of research, but I did look around and I did not see anything that says it would definately be compatible. I did contact Dell and talked with them. They said that Dell does not recognize any USB 3.0 I/O card that is “certified” by Dell to work in a a server. They told me to buy and install a tape drive back or similar instead of backing up to an external drive. At this point, I will just continue to use the external drive through the 2.0 port. Maybe if there is a solution from Dell, Plugable or NEC/Renesas, it will be posted here and I will be able to use the card in the future.


#9