USB 3.0 external hard drive recognized in 2.0 port but not 3.0 port.


#1

WD Elements Portable USB 3.0 external hard drive doesn’t show up when plugged into one of the front ports on my UD-3900 but does show up when plugged into back 2.0 ports.

I have the 3900 plugged into a Lenovo Idea Centre 730 running Windows 8.1. I’ve upgraded the firmware to 7.5.

Of course, I’ve plugged the 3900 into one of the USB 3.0 ports on the 730. Actually, it only has 3.0 ports.

Any advice you could give would be much appreciated.


#2

Tom, thanks for asking!

For the benefit of those that may come across this post in the future, Tom and I worked via email to resolve this.

We first determined that a Seagate drive worked on the 3.0 ports - the issue seemed limited to the WD drive. The fix ended up being to reinstall the chipset drivers on the system. After doing so, the WD drive started to work properly as well.


#3

Hi can I just check - I too have this issue with a WD drive (could the problem be that its a variable speed drive?).

If I connect the drive to the USB 3.0 port its not detected, but added to a usb 2.0 port on the replicator it works fine.

Is the cure to reinstall the drivers for the docking station again?

Thanks


#4