USB 3.0 Express Card problem with Seagate Goflex 1 TB


#1

I bought your USB 3.0 I/O card Express Card, I tried to attach Seagte Goflex USB 3.0 hard drives (1TB) bit nothing after 1 minute the light hard disk flashed and the disk didnt reconized. Only reconized usb drives (sandisk 1 GB, 4 GB, small sizes) What happened with Seagate Goflex drives?


#2

Hi Christian,

Thanks for posting your question here, I’ll be happy to help. Can you tell me more about your Seagate Goflex USB 3.0 drive? Is it new? Does it have data on it already? Does it work when connected to a USB 2.0 port?

Let me know these additional details and we’ll figure out next steps.

Thanks,
Jerome.


#3

Tx Jerome, I detail my scenario, Dell Latitude E6420, 02 HDD 1 TB FreeAgent GoFlex (with USB 3.0 interface and cable), 01 USB 3.0 I/O card Express Card (02 ports), these hdd works fine with USB 2.0 laptop’s ports, when I tried to use 01 hdd but didnt recognize, for test the card I connected a sandisk usb drive 4gb and recognize and worked fine. In my disk I have data (ntfs formated).


#4

Christian,

Thanks for the additional information. Let’s make sure that you are running the newest drivers for your card. Here’s a link to the download page, just download and run the installer, then try the Seagate drive again.

Thanks,
Jerome.

Plugable Technologies


#5

where is the link?


#6

Hi Christian,
Could you solve the problem? I’m facing just the same thing.
Mika


#7

Hi Mika HJ Kim,

Thanks for contacting us, we’ll try to help. Can you say more about your setup? Do you have the Plugable USB 3 Express card? What type of computer and which operating system do you have?

Let me know these additional details and we’ll figure out our next steps.

Thanks,
Jerome.


#8

Here comes my set up with trials so far.

Sony Vaio VGN-Z26LN
Vista Business Service Pack 2 (32bit)
Intel Core2 Duo P9500 @ 2.53GHz

Delock Express Card 1xUSB 3.0 (61872)

Every USB 2.0 pendrive works fine. (1, 2, 4, 8 GB with or without additional power to the Express card)

Any external hard disk cannot be recognised (with or without additional power(5v, 1A) to the Express card and the power source is not an USB port of the laptop.))

  • USB 2.0 external hard disk (without additional power)
  • USB 3.0 external hard disk (with additional power 5V, 2A)
    These two external hard disks work just fine with onboard USB 2.0 slots without additional power.

I updated the latest BIOS, USB 3.0 controller driver(Renesas Electronic 2.1.32.0) to have no luck yet.

Your help will be very much appreciated.

Best,
Mika


#9

Hi Mika,

Sorry to hear about the frustrating experience you are having. Because we don’t sell the Delock Express Card, I’n not able to give much support regarding it.

It looks like you have very new Renesas drivers so the only other advice I can offer is to verify one of your USB hard drives with a USB 2 cable and get it to work in the Express card in USB 2 mode. Then if it won’t work in your E-card, it’s probably the cable. Also, try another USB 3.0 port on another machine to verify your USB 3 cable.

Sorry I can’t help more.

Best of luck.
Jerome.


#10