USB 3.0 Docking station - ethernet jack stoped working after upgrading to Windows 10


#1

Windows 10 doesn’t seem to like the Plugable Ethernet driver. After Installing Windows 10 it seemed to work but a few days ago it stopped. I tried a Plugable USB 3.0 7 port hub with a separate USB to Ethernet adapter and it did the same thing. I tried installing the Plugable Displaylink Ethernet driver (it originally recognized it using a generic driver) and same results. Any suggestions or guidance would be greatly appreciated.


#2

Hi Steven,

Thanks for posting. I’m sorry the Ethernet driver stopped working for your docking station. I’d be happy to help!

The interesting detail is that you mention the separate USB to Ethernet adapter encountered the same issue…by any chance are you running Kaspersky Internet Security software? I have helped two customers who had similar issues and the root cause was determined to be the Kaspersky software blocking the installation. In those cases the customers completely removed the Kaspersky software and then they were able to install the drivers.

Of course, I may be putting the cart before the horse. Assuming you do not have the Kaspersky software installed, the first step is to perform a clean install of the DisplayLink driver for the dock (which includes the Ethernet driver) to see if that helps. Please follow these steps:

  1. Disconnect the docking station from your system.
  2. Download, extract and run the DisplayLink cleaner software --> http://www.displaylink.com/downloads/… to remove the driver from the system.
  3. Run Windows Update (Start > Settings > Update & security). Reboot when prompted. Repeat this process until there are no new updates found.
  4. Re-install the DisplayLink drivers from this link --> http://www.displaylink.com/downloads/…. Connect your dock when prompted during the installation.
  5. Reboot after the installation completes, and if all goes well, things should be working as expected once you’re back in Windows.

Let us know if that information helps when you have a moment, and we’ll determine the next steps from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

I do not have Kaspersky and the steps worked like a charm : )
Thanks for your help!


#4

Hi Steven,

Thanks for getting back with the update. I’m glad everything is working properly now.

Please let us know if you need any help in the future!

Thank you,

Bob


#5