USB 3.0 card reader fails/disappears on long reads/writes


#1

I just got the Plugable USB 3.0 PCIe card and a Lexar USB 3.0 external card reader in an attempt to speed up my CF card reads. I’m running Windows 7. Unfortunately, the drive “disappears” a few seconds into any read – the copy stops, saying that the files cannot be founds and the drive, while still appearing, shows as empty. There’s an LED on the reader and it goes from flashing during transfer to solid (briefly) about the time the transfer seizes to off. I have to reboot the machine to get the drive to reappear. I can get small amounts of data to transfer from reader to computer, but anything over about 10-15 seconds stops. I’ve tried a couple of CF cards. I haven’t experimented much with writes, but if anything they seem to seize up faster.

Given that the LED goes out (and reports of other problems I’ve heard about USB drives), I thought it might be a problem with power management, but I’ve tried changing the settings within the control panel and the driver utility without success.

I’ve got the molex power connected to the card, but it is on a line that supplies a fan. Any diagnostic that would report if it wasn’t getting enough power?

I don’t have access to any other USB 3.0 -equipped machines to test the reader.

Any ideas? Thanks.


#2

Hi Greg,

Thanks for your post regarding our PCI-express USB 3 card, we’ll be happy to help. From what you describe it could be a number of things.

To determine if the PCI-e card is failing, can you connect to a USB 2 device and see if it’s stable? Also, if you have another USB 3 device that would help to characterize the card.

Be sure you have the PCI-e card plugged into a 1X slot. Even though it will physically fit and may function to some degree in other speed PCI-e slots, it will only work reliably in a 1X slot.
As far as the power adapter goes, it actually will work without it connected at all, so no problem there.

Also, you can update the drivers for your PCI-Express USB3.0 card. The latest can be downloaded by clicking here.


#3

Thanks, Jerome.

I did update the drivers before the original post.

I tried a SATA drive in USB 3 enclosure and a SSD in a USB 2 dock and got pretty much the same result with each. Interestingly, when a read/write made the drive being accessed “disappear”, it had the same result on the other drive attached to the card as well.

The card is in a PCI-E x4 slot. I thought that PCI-E slots were fully compatible with the “smaller” cards. My motherboard (ASUS P6T Deluxe V2) does not have any x1 slots, though it does have a bandwidth-allocation option to run the last two PCI slots as x8 + x8 or x16 + x1. So I think I can force the last slot (though physically a x16) to run at x1 bandwidth. Would that be worth trying? Otherwise, as I don’t think any manufacturers make a USB 3.0 card in anything but a x1 configuration, I may be hosed.


#4

Hi Greg,

Thanks for all the good information. In looking at the documentation for your motherboard, it should support PCI-Express 1X correctly. It’s definitely worth while to set the last slot to X1, I’ll be very interested to learn if that’s a solution.

Let us know what you find!
Thanks for your patience and troubleshooting!

Jerome.

Plugable Technologies


#5

That seems to have done it! Both card reader and external HDD seem happy now that the interface card is sitting in the bigger slot that the MB is treating as x1.

Thanks for the help.


#6

HI Greg,

Thanks for following up and letting us know about your progress. I’m glad to hear your speed adjustment for the PCI slot worked! Just so I’m clear, was that a BIOS setting?

Thanks again for your troubleshooting and responses!
Happy New Year,
Jerome.

Plugable Technologies


#7