USB 3.0 10 port hub no longer working right


#1

I’ve been using this hub with no issues for about a year. I have the following plugged into it:

-Plugable USB 3.0 Gigabit Ethernet adapter
-a DisplayLink adapter
-A self-powered slim external HDD
-An old K120 no frills Logitech keyboard

My PC is an XPS 13 with 2 USB 3.0 ports.

Everything was great Friday evening when I shut down my PC.

Monday morning, I booted up and the DisplayLink and Ethernet adapters no longer worked. Windows gave me the generic “USB Hub power exceeded” message. If I unplug the displaylink, the keyboard and hard drive work, but the ethernet does not. With Displaylink plugged in, the keyboard no longer works.

I’ve tried rebooting at least 5 times to no avail. I also tried updating the hub’s firmware.

Any idea?

I’d expect the displaylink, but the ethernet adapter no longer works either, and the Hub is what’s erroring out.


#2

Sorry to hear about this issue.

Have you tried unplugging the hub completely and plugging it back in? (power first, then USB)


#3

That didn’t help. However, I tried a Win 7 system restore to back to where everything was working, and everything is now working again.

So, it appears some update was installed within Win 7 and it’s some kind of a driver issue. Any tips on how to figure out which one it is?


#4

It’s most likely the xHCI USB 3.0 host controller chipset driver.

Your XPS 13 should have an associated “service tag” which we can use to find what the latest driver is and manually install it.


#5

Since I haven’t heard back from you in a while. I’m going to close this thread. If you need further assistance please contact us at http://plugable.com/support/email

Thanks!


#6