USB 2 Gigabit Ethernet Adapter - OS X 10.8 Mountain Lion Problems


#1

Can’t get USB 2 Gigabit Ethernet adapter working on OS X 10.8 (Mountain Lion)

Have tried just plugging in to see if native chipset drivers would work - they didn’t. Read that upgrading from 10.7 to 10.8 can cause problems and the recommendation is to download and install the drivers, which I did, and it still doesn’t work.

I know the Ethernet cable / connection is good because it works just fine with my Thunderbolt adapter. However, when I try it with the Plugable, it is as dead as a DoDo, i.e. no lights flashing.

Can anyone help please?

Thanks in advance,

Ian.


#2

Hi Ian,

Thanks for posting! We’ll be able to help.

Just to check the basics - can you confirm that you have a Plugable brand adapter (because others will have different chipsets / drivers), and did you install the same driver as here: http://plugable.com/products/usb2-e10… ?

Did the install appear to make it through the whole install process? Here’s what it looks like: http://plugable.com/2011/07/27/howto-…

Let us know if it looks like things went wrong at a particular point in those steps.

The most common problem on a Mac is that you’ve done everything right, but that it gets a self-assigned IP address. These IP addresses always start with 169.

Thanks for letting us know - we’ll figure out next steps!
Bernie


#3

I’m having similar issues with the same adapter. It refused to work correctly on 10.8.1, so I installed the latest driver (3.6), and it’s now getting a DHCP address, but it seems to have broken AFP name resolution - I can no longer resolve .local.

Any ideas?


#4

Hi Mike, Thanks for posting! The ASIX and Apple drivers (both for ASIX USB Ethernet chips) are two different branches, and may have differences in behavior for area like AFP. Unfortunately, Apple does not develop or test their in-box drivers for all 3rd party hardware.

That said, what you’re seeing may be something solvable with configuration. Here’s a post that’s very detailed, but may provide some clues: http://stackoverflow.com/questions/68…

Also, ASIX now has an updated 3.8.0 driver. It doesn’t have any changes that appear to be relevant for your case, but it may be worth upgrading anyway. The latest driver is available here:
http://www.asix.com.tw/download.php?s…

Hope that background steers you in a direction that might help. Please let us know if there’s anything we can do to help.

Thanks!
Bernie


#5

Update: Installing the latest driver from ASIX solved Ian’s issue


#6

I updated to 3.8.0, but that doesn’t seem to have had any impact.
The issue is specific to the USB-GigE interface. If I enable WiFi, everything starts working as expected.

I can follow the suggestions in the linked posts and update /etc/hosts to include a line for the affected system, and that will work for basic file shares, but it still leaves one problem - namely that I can no longer see the Bonjour broadcasts from my TimeCapsule, so can no longer select it as a valid target for backups.

Any other suggestions?


#7

Update: It seems to be a problem with the adapter itself. I left the 3.8.0 driver installed and swapped back to the Apple 10/100 USB adapter and mDNS services (Bonjour and associated name resolution) started working again.


#8

Hi Mike - Interesting. The 10/100 and Gigabit adapters use different drivers. AppleUSBEthernet vs. AppleUSBGigEthernet, so that might be it.

But we would love to isolate this down to figure out where the limitation lies.

Could you email your Amazon order # (and a link to this topic for context) to support@plugable.com – we’ll see if a 2nd unit can help isolate things down more.

Thanks for your patience in tracking down this Bonjor type issue!


#9

Er, actually NO it didn’t! I cannot get any life out of my adapter, i.e. no flashing lights and just a red dot that sits against the ‘USB Gigabit Ethernet’ listing in ‘Network’ settings within ‘System Preferences’. Have tried removing the entry, adding it manually, changing the priority in the list - nothing!

Have also tried upgrading to 10.8.1 in the meantime, and have tried both 3.6.0 and 3.8.0 drivers - nothing!

If you can suggest any remedial action then please do, otherwise I will have to return the adapter.

Thanks, Ian.


#10

Ah, sorry! With the adapter connected, could you run this command from a terminal:
kextstat | grep Ethernet

And email the output to us at support@plugable.com ?

From that, we’ll know what driver version(s) are in use, and that should provide next steps.

Again, my apologies and thanks for your patience!
Bernie


#11

The replacement adapter seems to have none of the Bonjour related issues of the first one.

I left the driver as is and swapped in the new GigE adapter and everything is now working as expected.


#12

Hi Mike, That’s great to know! Just so we know for certain what driver version worked for you, could you go to a terminal and run the command
kextstat | grep Ethernet

And reply back with the output? Either way, we’re just happy to have you up and running. Thanks!


#13

It’s still v3.8.0.

Chiisai:~ mwallis$ kextstat | grep Ethernet
63 0 0xffffff7f81505000 0x9000 0x9000 com.apple.driver.AppleUSBGigEthernet (3.8.0)
96 0 0xffffff7f812b6000 0x7000 0x7000 com.apple.iokit.IOUserEthernet (1.0.0d1)


#14

Hi, found this thread while I was trying to get my Plugable gigabit adapter working with OSX 10.8.2. My experience is the same as Mike’s. I tried the recommended install procedure and the suggestions here:

http://plugable.com/2012/07/26/plugab…

No lights. No activity. It used to work in OSX 10.7. Still works on laptop with Windows 7.


#15

Hi Leonard,

Thanks for contacting us! Just shoot and email over to support@plugable.com with your Amazon Order Id, the serial number of the unit you have and a link to this thread and we’ll get you fixed up.

Thanks,
Jerome.


#16

Wow, that was quick. You guys are good!

Actually, the problem just resolved itself. It’s working now. I’m not sure what I did; I didn’t even restart OSX. After failing this morning, I took the computer up to the university to download Windows 8 in Parallels and when I brought it home and plugged in the gigabit adapter, the system recognized the device and I got a connection. Lights on and file transfers proceeding apace in OSX 10.8.2.

It might have something to do with different locations I had set up in OSX. I don’t understand these very well, but I’ve got a “Home” location and an “Automatic” location. Maybe switching between them got it going.

Happy now.

LF


#17

That’s great Leonard,

Thanks for letting us know!

Let us know if there’s anything else we can do.

Jerome.
Plugable Technologies


#18

Has anyone resolved the mDNS services (Bonjour and associated name resolution) problem? I have the gigabit Ethernet adapter and it works for IP but not for Bonjour and associated services.

Any ideas??? Thanks!


#19

Hi Wesley-

Can you please verify the serial number on your device?

I believe the issues around mDNS stem from having the ASIX driver installed on an older adapter that can work with Apple’s in-box OS X driver. For adapters on sale today, installing the ASIX 88178 driver is required for the adapter to work (for both IP and mDNS).

I suspect you might have one of the older units with a serial number beginning with a 5 or a 6: if so, we actually need to uninstall the ASIX 88178 driver so the adapter loads Apple’s in-box driver to get mDNS based services working.

With the additional information about the serial number on your device I can recommend the next steps.

Best wishes-

Jeff Everett
Plugable Technologies


#20

I have this issue with a serial number beginning with 108. Is there a fix, or do I need to exchange the unit?