USB 2 File Transfer Cable Transfers Only Part of Larger File


#1

I am trying to transfer a 43.9 GB file from Windows (have tried both Vista and Windows 7) to Mac OSX 10.6.7 using the Plugable Technologies "USB 2.0 File Transfer Cable for Mac and Windows Systems"and in the GO! Bridge software the file continuously shows up as being only 3.99 GB. Each time I attempt to transfer the file it stalls at 4.3GB and results in an incomplete transfer. I was led to believe that there was no upper file limit on file transfers. Any idea what might be going wrong. I’m quickly approaching the point of frustration with the product.


#2

Hi Ronald,

Sorry you’re seeing this problem, it’s definitely frustrating because there is no limit on the file size our product can transfer. There are however, things that can disrupt the transfer and it seems there’s something going wrong on your setup.

Do you use a hub on either side to connect the USB 2.0 File Transfer Cable?

During the transfer, did you disconnect any other device connected to either computer?

We’re looking into this and trying to reproduce the problem on our side, we’ll report back as soon as we know more!

Regards,
Lampros


#3

Hi Lampros,

I really appreciate any help you can give me. To answer your questions:

  1. No hub on either computer … I’m attached directly from computer to computer.

  2. Nothing was plugged in or unplugged from either system during the transfer.

I tried the whole process on two different PC systems (same Mac system) several times each with the same result.

The really odd part to me is that the GO! Bridge software itself is showing the file as only being 3.99 GB in size when the operating system on the PC is clearly showing it being MUCH larger.

I’m very much looking forward to seeing what you come up with on your end!


#4

Hi Ronald,

After investigating this issue we reproduced the exact same problems you are having. It seems transfers from our Windows 7 computer to a Mac 10.6.7 suffer from the following:

  • File size equal or over 4GBs is reported incorrectly - in more detail: it seems the file size is reset when over 4GB. E.g. a 4GB file is reported as 1 byte, a 5GB file is reported as 1GB etc.

  • Transfers work fine up to 4GB but at that point stall - they seem to continue from the Windows side but even when Windows reports that they’re done the files are still unusable on the Mac

This problem does sound similar to how some filesystems have a 4GB limit (namely FAT32), but shouldn’t affect NTFS (Most Windows Vista and Windows 7 installations should be NTFS) or the Apple filesystems (http://en.wikipedia.org/wiki/File_All…).

Unfortunately we were unable to find a solution or workaround to this problem, so at this point we would like to offer you a refund.

If your order is under 30 days old you can do a return using Amazon - found here: http://www.amazon.com/gp/css/returns/…

If your order is over 30 days old, please shoot us an e-mail at support@plugable.com with your Amazon order number (if possible) and we’ll take care of it.

Regards,
Lampros


#5

Hi Ronald,

I’m very sorry about this Mac-specific 4GB file-size limit in the Go Suite Mac software. We hadn’t caught it before. A return and full refund is totally understandable, and no problem at all, as Lampros said. If you go that route, I’m sorry for the trouble that will take.

Two longer-term things we’re doing:

  1. Updating the product listing to mention this 4GB limit on Mac.
  2. Contacting Oti (the chipset maker) and Go Suite about the Mac software limit to push them to solve this issue in a future version of the software.

Again, sorry you hit this and thanks for your patience while we worked to understand the issue!

Thank you,
Bernie Thompson
Founder, Plugable Technologies


#6