USB-2 Cable Lights Not on

My new USB-2 Cable worked flawlessly in copy old files to new computer. In the YouTube video, it says that you will see lights on the cable when connected. Mine never displayed any lights, but all else worked okay. Anyone have any comments about the lights not being on?

Thanks for your post! I’m sorry to hear about the issues your experiencing with the lights on transfer cable. I’d be happy to help you troubleshoot.
If you haven’t done so already, I would recommend restarting your computer, plugging the cable into different USB ports, and also try swapping the cable ends around to see if that gets it recognized properly.
If you need further assistance, please leave the cable connected to your computer, then download and run our diagnostic tool from this link: The tool will put a results folder on your computer’s desktop view. Please email the folder to us directly at: with Ticket #330242 in the subject line.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.