USB 2.0 to Fast Ethernet port not working.


#1

Plugable usb 2.0 docking station - ethernet port not working. I have tired several different drivers, but nothing works. Win 7 Home Premium 64 bit OS - Intel Core i5.


#2

Hi Michael,

Thanks for contacting Plugable. Sorry that you are not having a plug-and-play experience with your dock. We’re here to help.

If connecting the dock to your PC did not result in Windows getting the drivers for the network adapter via Windows Update, you can download and install the Win 7 64-bit drivers manually from the link to the ASIX site on this page: http://plugable.com/products/ud-160-a…. Let me know if these are the drivers you installed. If so, we’ll take it from there.

Again, I apologize for the troubles a Plugable product is causing you. Just let me know if this information has helped you get the dock connected or if you still are stuck.

Best Regards,

Aaron
Plugable Technologies


#3

Hi Aaron,

I tried the Win 7 64 bit, the 32 bit, and the 32 64 combo driver. I got desperate and even tried the Vista drivers. Does sound like a hardware issue, please advise.

Thanks for the help,
Michael


#4

Hi Michael,

I’ll take this off the public forum to get additional information from you. Look for an e-mail from support@plugable.com on this topic to continue the discussion. When we reach a solution, if the answer can benefit other customers running into the same situation, I’ll post it here.

Thanks,

Aaron


#5