USB 2.0 sharing switch not working with Windows 7


#1

I have 2 Windows 7 (64 bit) computers that I am trying to connect to a printer using the USB 2.0 sharing switch. Both computers give me a code 43 error (windows has stopped this device because it has reported problems). The drivers for the printer are on both computers and I can use it from either computer when connected directly (not through sharing switch). I have tried restarting while connected through the switch and the printer starts and stops repeatedly and windows does not completely load on the computer. Any ideas as to what the problem is ? Thanks, Michael Church


#2

Hi Michael,

Thanks for contacting Plugable. I’m sorry something is going wrong with your printer connection since you introduced the switch into your configuration. To test that the switch hardware is working properly, can you try the following simple test?

  1. Connect both computers to the switch.

  2. Plug a simple USB device like a mouse or a keyboard into the switch.

  3. When the LED on the switch is green, computer A should have access to the mouse. Does it work properly?

  4. Press the button on the switch. The LED should now be red, and computer B should have access to the mouse. Does it work properly?

Let me know what results you get, and we’ll proceed from there.

Best Regards,

Aaron
Plugable Technologies


#3

Aaron,
Thanks for the reply.
I did what you said and both worked with a mouse. The printer is a Brother MFC 8860DN if that makes a difference.
Let me know how to proceed from here.

Michael


#4

Hi Michael,

Thanks for getting back to me. It’s good that we can rule out a faulty switch.

Next test: Can you try a different cable for connecting the printer to the switch? If the printer uses the same kind of cable as came with the switch for connecting the two computers, you could just connect one computer with one fo the cables and use the other cable to connect the printer.

Let me know the results, and we’ll go from there.

Best Regards,

Aaron
Plugable Technologies


#5

Aaron,

Thanks again for the prompt reply. I switched the cable from the switch to the printer and everything works properly now. Doesn’t make sense to me, but if it works I am happy. I used one of the cables that came with the switch.

Thanks again,
Michael


#6

Hi Michael,

We’ve found that the additional hops the data has to make when the switch is involved can expose devices cables that might have worked fine with a direct connection to a PC.

I’m glad we found a solution. Let us know if we can be of help in any other way. Thanks for going with a Plugable product. For any additional issues, don’t hesitate to contact us again.

Best Regards,

Aaron
Plugable Technologies


#7

Having same issue with an HP printer. Tried the simple device/mouse thing and it did not work. I noticed when switched to “B” I get a blue light, when on A I get a green light. Tried all kinds of cable combinations.


#8

Hi Rodney - Thanks for posting. If you manually move the printer’s cable between the two computers, does it work on both? This is a good double-check that all the right drivers and configuration have been done on both machines. This is a passive, physical switch – pressing the button should be exactly like moving the cable between the two machines.

Email support@plugable.com anytime if you’d like us to help with the particulars of your situation - we’d be happy to. Thanks!


#9

yes both computers print when hooked up individually.


#10

Great. Thanks for ruling out that kind of software issue. Please just email your Amazon order # to support@plugable.com and link to this thread, and we’ll work on the hardware. Thanks for your patience!


#11

Hi,

I am having a similar issue. I am trying to plug a 2-port hub with mouse and keyboard into a Windows PC and a Mac.

Mouse and keyboard works when the switch is green. When the switch is blue the Mac simply ignores the keyboard and mouse while Windows gives me code 43. The mouse and keyboard work when plugged directly into the computers and when plugged in via the hub.

It seems that the issue is the “Computer B” switch setting.

I get the same issue when I simply plug a mouse into the switch. I.e. no hub, just 1 mouse shared between the PC and a Mac. Works when switch is green, but not blue.

Regards,

David


#12

I have a similar issue in that the first time I plugged in the usb 2.0 sharing switch into my win 7 laptop it worked fine. I switched it to my win 8 laptop and it worked fine. But when I switch it back to the win 7 it does not recognize the usb device and neither does the win 8 machine when I switch it back. If I power down my printer (brother mfc-490cw) they both work fine the first time. But then nothing.


#13