USB 2.0 Microscope. No light, no camera

Just purchased the above. Have no idea of what model and can’t find it in your dropdown. In any event, successfully downloaded software but no visual or a light appears. Tried through my Windows 10 Camera App (Lenovo) and basically same thing. Is there a covering or tab I am supposed to remove? How do i get to 200x magnification once i get in? I’m not planning on using time lapse photography. I chose the highest resolution available. Tried the lowest and no change. What are my next steps? As new user, can only upload one pic but have others available.

Hello Trina,

Thanks for reaching out to us about this. I’m sorry for any trouble, and I’d be glad to help you. Just so I am clear, is this our USB2-MICRO-250X 250x Microscope that you have? First, I would suggest to check and make sure that Privacy Permissions are properly set to allow access to the microscope using the steps in this article:, then restart the computer, let’s try another USB port and try the Digital Viewer again.

As for magnification, it’s a crossroad between how far away you physically are from the object you’re examining and the amount of focus used to examine. At the closest distance with the clear shield touching the object, there are two possible magnifications. The first is at around 50x, but if you continue to rotate the focus wheel, the image will get blurry, then sharp again at a much higher magnification.

There are two focal points with the clear shield touching whatever you want to view. Can you try the following with the Digital Viewer app open:

  1. Remove the microscope from the flex arm
  2. Place the microscope on the observation pad grid, nose-down, resting on the clear shield
  3. Rotate the lens mechanism fully in one direction until it stops
  4. Rotate the lens mechanism slowly in the opposite direction while observing the changes in the preview window

If you do this, you should see a clear focus at two magnification levels. I hope this helps you! Please let me know if you have any further questions.

Thank you,

Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.