USB 2.0 Gigabit Lan adapter stopped working after upgrade to macOS Sierra


#1

Hello, I have this adapter that worked really well in OSX El Capitán

https://www.amazon.es/gp/product/B003…

Today I upgraded to macOS Sierra and it stopped working. It looks like the device isn’t recognized at all.

USB Ethernet still works in my computer using an Apple adapter.


#2

Hi,
Follow the installation procedures come-up with the device, Its needs to be configured after the update. Mine working after re-configure.


#3

Thanks Kim.

Do you mean installing the drivers? According to the official page, this should not be needed. I tried installing them anyway, but it didn’t solve the problem:

http://plugable.com/products/USB2-E10…


#4

Hi Jaime,

Thank you for posting the question here.

As you’ve already noticed, unfortunately the chip set manufacturer ASIX hasn’t provide the device driver of the USB 2.0 Gigabit Ethernet adapter (chip set AX88178) yet. As far as we have tested in-house, the adapter won’t work after upgrading into 10.12.

We’ve also tested our USB3-E1000 USB 3.0 Gigabit Ethernet adapter (chip set AX88179) and USB2-E100 Fast Ethernet adapter (AX88772) with 10.12 and the latest device driver, then verified they worked fine.

We’ll contact ASIX to see if they could provide the Estimate Time Arrival of the newer driver for Mac OSX 10.12. If we could get the answer, we’ll update it in here.

Thank you for your understanding.

Sachiko
Plugable Support


#5

Plugable hasn’t updated their Drivers page, but it looks like ASIX released an updated driver a month ago. You can get it from:

http://www.asix.com.tw/download.php?s…

Installing that fixed the problem for me.


#6