USB 2.0 Ethernet Adapter Does Not Connect for Me???


#1

Hey, I’m Will.
I recently acquired a USB 2.0 Ethernet Adapter to convert my dialup line into a workable line for my laptop (a 2011 HP G62 with Intel Core 13). Sadly, after finally being able to install it, it notifies me that it’s not recognized by the computer. I tried troubleshooting the problem, and the computer came up with nothing- both on just the connection end and the device end itself. If it helps, the Link and ACT lights don’t light up either. I’ve been unplugging and plugging it in and still nothing. I even tried adjusting the settings of the connection setup, and still nothing. I’m not sure what’s going on…how can I fix this???


#2

Hi Will,

Thanks for posting your question here, I’ll be happy to help. First we’ll want to verify that the ethernet cable you are connecting to is alive and well. If you connect it to the on board ethernet on your laptop (it should be on the left side of the laptop as you face it) can you see the link light? If there’s no light there either, we’ll want to troubleshoot the ethernet connection back upstream.

Can you say more about the network? Particularly what is up stream on the ethernet cable. If it’s a router that you have access to, it may help to power cycle the router.

If you are thinking you may have purchased the wrong item, no problem, just send an email with your Amazon Order Id to support@plugable.com and we’ll get you fixed up.

Thanks,
Jerome.


#3

I just tried and the Link light did not light up. How do I troubleshoot the connection upstream??? I tried troubleshooting the modem (in Devices in the Control Panel) and the connection itself (in the lower right hand corner of the screen).

I’m not sure exactly what you’re asking. The ethernet cable is hooked into a wall where my dialup phone jack is. This computer does not allow me to select the external modem- instead it goes right to a Novatel Wireless Modem…

I have no idea if this helps you at all???

Honestly, I don’t know if I ordered the wrong thing. I have a phone line jack and a 12 foot long dialup cord that you could also use for a telephone/fax. Would that work on your product???

Sorry- I’m not very savvy at configuring stuff like this,
Will


#4

Hi Will,

Thanks for the additional information. It sounds like you may have purchased the wrong item. You’ll need an ethernet enabled router or similar device to connect the Ethernet adapter to. Although the physical connections are nearly identical, they are in fact different and not interchangeable. You can get a refund from Amazon if you are within 30 days. Here’s a link to do that:

http://www.amazon.com/gp/css/returns/…

Otherwise if you are over the 30 days just send your Amazon order Id over to support@plugable.com and we’ll get you fixed up.

Sorry I didn’t have better news.
Thanks for your patience,
Jerome.

Plugable Technologies.


#5

Jerome,
Thank you for being so helpful. I was misled by the amazon reviews. I’m sorry; I’m not good at technology (as you can tell). Good thing it just arrived today and I have the stuff and all. Thank you so much for your patience with my level of technological skill (or lack there of).

Thanks again,
Will


#6

Hi Will,

No Problem, thanks for the kind words! Just let us know if there’s any thing else we can help with.

Jerome.

Plugable Technologies


#7